WD MyCloud Gen2 - Enable apps install tab + Apps!

I have to say - WD is not for 4k dlna streaming. At mkv files (50/60GB) its just too slow. Unfortunatelly… For 1080p great enough :wink:

Yeah I cant stream 4k or after than 13mbps 1080p on a dedicated Computer i7 15gb 256gb SSD, I have not tried any files on my MyCloud.

Ok I think I overload Plex. It was working fine after I added a Share “Movies”. but think I gave the little CPU too much work to do when I added over 10,000 photos. The dashboard became un responsive for days. I figured It was doing it thing making thumbnails ect. After 3-4 days I had to manually pull the plug and reboot Since I could not get to the dashboard. I did Have SSH enabled but did not find and commands to restart Plex. Now im asking what to do. When I am in the Dashboard and click Apps plex shows up. I click configure and I get " Safari cant connect to the server immediately " Not even a pause. I tried turned the server on and off from dashboard and waiting 10 minutes but still the same results. What can I do?
I was over joyed when Plex worked. Then I could shut down my PC that would have to Run 24/7.

thanks in advance. I do have SSH running. But dont know the commands.

Ok I got it to work I Re-Installed Version WDMyCloud_plexmediaserver_1.18.0.1913
the was the latest version I saw on https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Apps/ (also did a reboot) then Wala Plex was back!

But open configure plex in the dashboard I was told there is an update (below) is that safe to install? or are these versions we use for the MC special versions?
PlexMediaServer-1.18.4.2171-ac2afe5f8-WDMyCloudEX2.bin

thanks again for ALL of your help. Im not just a forum leech I like to give back to the community :wink:

Hi,

I just got my WD My Cloud and I would like to install “WD_Crack”.
I tried the alternative way:
Press [ctrl] + [shift] + [i], open “Console” tab, put this and hit [enter]:
APP_INSTALL_FUNCTION=1; APPS_EULA=1; check_app_eula();

But after loading I get “No available Apps.”

I am on the latest firmware (2.31.204). My Cloud has access to the internet, ports are all set.
Anyone know why I can’t see the apps? I think it has something to do with the firmware.

It took me several tries. I think I remember trying an older crack first them upgrading to the 1.2 v

https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Apps/

Hey lotus,

How do you install the older crack? Are there steps that I can follow?

Am I doing it wrong by going to console in the browser and using
APP_INSTALL_FUNCTION=1; APPS_EULA=1; check_app_eula();
then going to “Apps > App Store” ?

Yes that should work. Its a pain to get rid of the EULA agreement. But you will eventually get a box that says install App. WD may warn you that its not an official app. Just click install or agree.

sometimes you have to leave the apps page then return and copy and paste

Blockquote. 2. javascript:APP_INSTALL_FUNCTION=1; APPS_EULA=1; check_app_eula();

Sometimes Copy and paste does not work is I paste that into my MayBooks “Notes” I have to return to the very first page here and copy the line. I dont know why.

Are you sure? I feel like I’m doing something wrong.
Is there no other way to install the crack?

No other way that I know of. Im also on FW:2.31.195 not the latest. They might have killed installing 3rd party stuff all together.

That ■■■■■. The main reason why I bought this NAS was to install PLEX on it… Should have bought the My Cloud Home *sigh

You do not want the My Cloud Home. While it can run Plex it has fewer features/options than the My Cloud line has as many have discovered after buying it. The single bay/single drive My Cloud was never designed to run Plex. While one can hack the firmware (primarily of the gen 2 v2.x firmware single bay My Cloud) to run Plex, it may not run correctly (or may run slowely) nor can one typically transcode streams on the single bay My Cloud.

Being honest if you want to run Plex there are better options than trying to run the Plex server on hardware not designed for it. Look at the Plex NAS compatibility chart that lists numerous other NAS devices that support running Plex. Some (TerraMaster for example) can be had for almost the price of the entry level WD My Cloud line. The downside is the firmware of lower cost NAS boxes may be just as issue prone as the firmware on the single bay My Cloud line.

One could even run Plex on a Raspberry Pi and use the single bay My Cloud as the Plex library location. It’s what I did for over a year before bumping up to a Plex supported NAS (a Synology server on sale during the recent Black Friday). One can often (if one is very patient) find Synology or Qnap NAS’s on sale at prices a little more than the cost of some WD NAS devices.

1 Like

Yup look on ebay for the myCloud Home VS personal the older gens fetch more money for the educated user.

Hi, did you find a way to solve the "The system is booting up, please wait.” after Sleepfix? It happened to me as well (see here - How to delete Sleepfix - unbrick?)

I also don’t have SSH enabled and am considering either the serial console or this - Unbricking without opening

UPDATED
Latest firmware 2.31.204
for convenience install this addon:(or something equivalent for your browser)
https://mybrowseraddon.com/custom-style-script.html

add this code to the javascript injection box:

if(window.location.pathname == '/web/addons/app.php', 'nav_addons') {
    function func(){$(".header_1 ._text").append('&nbsp;&nbsp;&nbsp;&nbsp;<input type="file" name="f_apps_file" class="file_input_hidden" id="f_apps_file" onchange="apps_manually_install();">')}
     $(document).ready(setTimeout(function() { func(); }, 1000));
}

on the url field put:
http://wdmycloud.local/
exactly like this unless you changed the domain name
it cant be the IP, I don’t think it works with this browser extension

This will add a button to install apps
if it disappears just reload the page
install WDMyCloud_WDCrack_1.2.bin
it has to be version 1.2 or 1.1
version 1.0 does not work with this script
from Fox_exe and you are done!

3 Likes

just try your method for convenience,nothing happened… does css should be empty?

check the post up, I updated the code for “un-cracked” firmwares

thanks for replying

still failed。。。but anyway,thanks for your post~

it works!!! thanks

1 Like