WD MyCloud Gen2 - Enable apps install tab + Apps!

I am trying to install a Git Server on my Gen 2 but I can’t get to install Git. I really don’t understand why it is such a hazzle. I’ve tried installing WDMyCloud_WDCrack_1.1.bin and WDMyCloud_WDCrack_1.0.bin following your steps but I get an error; Failed to install app. Any suggestions?

You realise this is an English command, not a linux command, right?

I’m not sure if you have to put the downloaded define.js into the /Public folder using a linux cp command under SSH, or whether you can simply copy it into /Public using the normal file server access (e.g. under Windows or MacOS, etc). I suspect the latter, and that step 3 can be done before 1&2.

The sequence of commands for the installation is:
using a file manager, copy the define.js file to somewhere in user space (somewhere in /Public; it shouldn’t matter where)
login to the linux OS vis SSH
delete the existing define.js file (the rm command)
create a symbolic link to that file (the ln -sf command) in the place of the old define.js file; if you’ve put it somewhere other than the top level of /Public, you’ll have to give the full path
set it to full rwx permissions (chmod 777).

Essentially we’re replacing the existing define.js with Fox’s version, but putting it in /Public so it won’t be obliterated when the device reboots and unpacks the OS.

Hmmm… I thought this explanation sounded familiar…

Ok, understood that part. I only didn’t understood my my cloud version. It is called only “My Cloud”. Everybody says gen2 or 1 but I don’t understand what that means hope you can help me.

Can anyone really describe me what to do from the beginning. and the model of my my cloud? it’s a 3tb model.

Go to the Dashboard home page.

If the firmware version it reports is v2.xxx, it’s Gen2.
If the firmware version it reports is v4.xxx (or v3.xxx), it’s Gen1.

Thanks, mines a Gen1. So will this “Dirty Hack” work with Gen1?
If yes, can you explain from the beginning in a simple way what should I do?

No.

Hence the thread title…

But in the download links there is a folder called Gen1?

And I want to install the 2.0 firmware to my gen1. When I manual update with the firmware file, will it work? Currently it’s v04.

I don’t want to try it, because I have a lot of data in my cloud. I don’t want them to be gone. I searched for how to unbrick a My cloud, and it needs to be disassembled. I just need to be sure.

You can’t install v2 firmware on a fen1 My Cloud. Different hardware.

You CANNOT install the v2.x firmware on a v4.x single bay My Cloud. The 2nd gen v2.x single bay My Cloud has slightly different hardware than the 1st gen v3.x/v4.x single bay My Cloud.

Because you traversed up the hierarchy of the fox_exe’s repository, into the Gen1 area; that’s not part of this app installation hack. Fox_exe has also done development work on the Gen1 devices. And the EX family.

I succeded in apllying the steps including refreshing my cloud… The “Install an app manually” button appears but I am stucked at the Acceptance form when I click on it. The acceptance form is opening and the Accept button doesn’t respond in any way on click… Do you thnik you can help me with a solution for this, so that I can reach on installing PhpMyAdmin app?! Thanks in advance for your time!
PS: “Or maybe there is another way to install the phpmyadmin app directly from define.js file by modifying it in some way”

Hi chrradu,

You can run the following on browser console to bypass the License acceptance form.

APPS_EULA=1; check_app_eula();

Click on the Install link again to select the file.

Thanks for your answer… I managed to pass through this step too… The only problem I have now is that I can’t configure the MySql server with my admin user from the WD My CLoud: #1045 Cannot log in to the MySQL server. Any idea how to solve this one too?!

Take a look at the following post

https://community.wd.com/t/setting-up-sql-db-how-to-get-phpmyadmin-working/97754

Hello, someone have an update for Milestone Arcus Surveillance App? the version in the repos (2.5325088) wil not allow (anymore) to get free licenses redirecting to this info page

http://shop.wdc.com/store/wdus/html/pbPage.MilestoneSoftware_OldVersionPage/ThemeID.40263900?id=milestone&sid=

that basically ask to update the app

Hi Fox, how you doing?

How do you get updated versions for the media server? I tried several times to update using the file downloaded for the website, but I found an error every time. Its`s just possible with your files, how do you get those files?

You modify the original files? Can you teach me how to do this?

Thank you in advance!