WD MyCloud Gen 2 Won't Recognise WD MyBook 8TB USB

Hi folks, as in the thread title.

Reaching a point of some frustration here trying to get a brand new, just arrived today, WD MyBook 8TB recognised in the MyCloud USB expansion port. I found a couple of threads about the same problem and the suggested solution is to unplug the expansion drive, then reboot the MyCloud, then plug in the expansion drive and you’ll be able to map it as a Network drive in Windows. Still no joy. Also read to quick format the MyBook as NTFS, done it but still cant see it in Windows or the MyCloud control panel.

Previously always had this working fine with 2TB USB drive as expansion.

Any help would be appreciated, obviously I want to get it setup and start re-organising stuff. TIA.

Edit: Update. Just did a network reset in Win 10 network settings, rebooted, still cant see the plugged in MyBook.

A troubleshooting suggestion. Delete all the partitions on the MyBook drive then create one single partition and format it for NTFS. This can be done using Disk Management in Windows 10.

Backup any files on the MyBook drive as deleting partitions will erase all data on the hard drive.

1 Like

Thank you, will try in a few minutes. I’ve just restored a clean image of Windows 10, and also used the WD Quick Formatter tool mentioned in this thread but still cant find the USB MyBook on the network! Couple of Windows updates downloading and installing atm, will try your suggestion after. Thank you.

Apologies but I don’t know how to quote a post with this forum software. Removed partitions in
Windows Disk Management, created new NTFS drive (quick format). See it fine in Windows but still cant see it on the network. Rebooted Windows searched again but no different.

03 04

Edit: I’ve just noticed a couple of “Unsupported File System” notifications in Control Panel - Code 1121?

“Unsupported File System
An unsupported file system has been detected on a USB device (vendor Western_Digital, model: My_Book_25EE, serial number: VDHTHS0K, file system: N/A, label: N/A). Please remove the USB device.”

Just used Low Level Format Tool to Quick Wipe (Remove MBR and Partition Table), re prepped in Windows Disk Management (GPT partition type ?), quick reformat, still no joy, see it in Windows fine, but still wont show up on the network. I chose this MyBook as I assumed there would be a high level of compatibility, but searching the forum this is clearly a very common problem. Going to bed. Would greatly appreciate any ideas/suggestions. TIA.

I am a bit confused as to what you are trying to do with the My Book device. Have you attached it to the My Cloud’s USB port? If so what does the My Cloud Dashboard indicate when you click on the USB icon(mycloudusbicon) at the top of the Dashboard page?

The My Book, since its a USB device will not show up under the Network Neighborhood when it is connected to the My Cloud. Instead, if the My Cloud properly see’s an attached USB hard drive it will show up as a new Share in the My Cloud Shares list and can be accessed once you have opened up the My Cloud Shares listing in Windows File Explorer.

Well would you believe that after leaving the MyCloud turned off overnight (never normally do that) and booting it up this morning, leaving it a short while, and then plugging in the USB MyBook, the MyBook was instantly recognised in Control Panel (now showing 12TB) and instantly appeared in My Cloud Shares listing in Windows File Explorer, from where I was quickly able to map it as a network drive.

I’ve now started transferring several TB of data to it from various other USB drives (long job).
I can only assume this is the same glitch/bug others have mentioned with this same problem, some sort of cache where the MyCloud remembers what was plugged into its USB, or some form of corruption of that!?

Last night spent a few hours trying, this morning I did nothing different, but it was instantly recognised. My only concern now is when I power off the expansion drive, will it be immediately detected again, fingers crossed. :crossed_fingers:

Thanks for your time and suggestions. Appreciated.

Edit: I’ve just noticed that in addition to all the hundreds of Gigs of missing folders, I also have some files identifying as folders. I’m guessing that something, a config file or such like on the MyCloud is corrupt. In view of my experiences and the numerous threads where ppl have similar problems via the MyCloud USB I’ve decided to scratch the idea, it’s obviously buggy and unreliable. The MyBook will be used as a straightforward USB drive in PC. WD really should address this problem, ppl shouldn’t have to jump through hoops to get a USB expansion working and reliable.


This is proving a disaster. Yesterday, once the MyBook had been recognised in the USB expansion port, I copied over a TB of data to it (TV Series into a folder named TV) and all went great, all files were okay, playing fine. Powered off the MyBook last night, powered it on this morning!

In the screenshot below, everything with two dashes before it in the left hand window was copied to the MyBook yesterday (as mentioned ALL worked fine), this morning the right hand window shows the MyBook folder!!! Now, every time I copy to the MyBook it fails and crashes the MyCloud requiring it o be re-started! I’m assuming that powering on/off the expansion drive overnight has caused some type of corruption on the MyCloud? Fortunately all files in the MyCloud seem fine.

I’m stuck, any help would be greatly appreciated. TIA.


Couple of comments. From my experience with experimenting with OSMC and Kodi on a Pi last year, I didn’t have too much difficulty mapping the My Cloud to it. Both OSMC and Kodi would access and play the media files on the My Cloud.

One thing though, using special characters in file/folder names will present issues on Linux that may not appear when the USB drive is connected to a Windows PC. This can include problems with copying files or how Linux based OS’s like OSMC and Kodi on the Pi can access/see the files. It is best to follow proper naming conventions for the media server/application you plan on using.

I ran into a similar issue on the Pi when using Plex with the media files residing on the My Cloud. Special characters caused issues and it took me hours to go through and fix the file/folder names so the media server would properly read the files.

1 Like