WD MyCloud EX2 blinking HDD LEDs all the time (Media Sharing disabled)

Hi guys. I’ve read here in the forums some users relating a high-CPU activity of the My Cloud EX2 and the front LEDs blinking all the time, due to the Media Sharing feature. Mine here is in the same situation, with the LEDs blinking like crazy and a floating CPU activity (with no device connected to the NAS to generate file transfers), except for the Media Sharing which is disabled. I did copy tons of files to it weeks ago, but it’s been already more than two weeks that I’ve finished it and the NAS is still with this heavy load. The Media Sharing feature has always been disabled, so theoretically there’s no such thing as ‘files indexing’ going on. I’ve tried to reset it to the original settings as well as an electrical reboot, but none worked. It stays on night and day, 24x7 and I think that even with a certain file indexing going on, two weeks without copying any other things is more than enough to finish whatever it’s trying to do…


My setup info:
Win 8.1 x64, WD My Cloud EX2 w/ FW 1.04.05.

Any ideas?

Thanks! Regards,


Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


1 Like

There seems to be an indexing process going on in the background for loooong after transferring media files to the ex2, even if dlna is disabled.

Look here:



1 Like