WD MyCloud DL4100 - Stuck in boot loop

Hello there everyone,

so…I have been using my MyCloud DL4100 for about 2 years now.
It has always been working like a charm, then yesterday I could not connect to the device anymore, nor over Dashborad or to the drive folder it self. The LED-Screen read: “Firmware Update”. I tried everything to access the device, even left it for several hours with the “Firmware Update” message. Nothing happened. I then tried to forcefully reboot the device, thinking the OS crashed and hoping the Firmware did not start updating by itself.

For about 6 hours the device has been turning on and off, blue LED always blinking, no message shown on the LED-Screen and the Fan-Speed is always high up, like in a constant boot sequence.

I have read that WD Claims to give it as much time as needed, as it may be doing a systems file scan. But I doubt it is, as it does always turn off and then shortly after back on by itself.

I have even tried the hard reboot with the clip on the reset button and 40 secs while turning it back on…
Has anyone got an idea what is going on with the device?

It has been working perfectly until yesterday.

If you haven’t done so already you may want to search (using the magnifying glass icon upper right) through the dedicated DL series subforum to see if there are similar questions to the one you posted here. There may be people more knowledgeable about the DL4100 in the dedicated DL subforum as well.


Hi -

did you ever get this resolved? I’m running into the exact same issue right now.

Thanks so much!

  • olaf

Hey Olaf,

I got a replacement. It turns out that due to the firmware upgrade some resistance burned through. It took me a while to get WD to accept the claim, but once the reason was clarified they sent me a new case!

Beat regards

Where you in or out of warranty when they replaced it?

I’m out of warranty

If anyone know how to repair this DIY, I’d love to read a guide on it

If you have a My Cloud DL4100 then see the dedicated subforum for the DL Series where users more familiar with that device (and fixing issues specific to that device) may be able to assist. This subforum, My Cloud, generally discusses the single bay/single drive My Cloud which is a different device than the DL Series of devices.