WD MyCloud Desktop App

Hi new user here so what I’m about to ask may well be common behavior? (But I doubt it?)
Windows 10 machine with networked 3Tb MyCloud - on opening the Desktop WD MyCloud app and clicking through the security alert, opening the ‘shared pictures’ folder (and any subsequent folder) I open a picture to view, click on ‘next’ (in whatever viewer I decide to use) and what then opens is the next picture in my Machines local User\AppData\Roaming\com.WD.WDMyCloud\Local Store\ and NOT the next picture in the ‘shared pictures’ folder on the MyCloud device!
If I close it all down and start again choosing a different picture and scroll ‘next’ then my last picture (and any other I’ve opened previously) is/are displayed from the \Local Store…?!

Using a Windows 7 Laptop (and the same viewer program), my Android mobile and tablet they all work as I’d expect.i.e. clicking ‘next’ displays the next picture in the ‘Shared Pictures’ folder.

Hi, it is not a common behavior, have you tried uninstalling and re-installing the application? Which version of the WD My Cloud app are you using?

Hi Iluna, thanks for taking time to reply. is the version of WD MyCloud. I contacted WD Support regarding the issue and was told it was legacy software no longer available for download so not supported and to use WD Access instead, I then told support that I have already tried WD Access and every time I boot my PC I’m informed that the MyCloud device is downloading/installing new firmware 2.21.119 and rebooting - But it is already running that Firmware! It was explained to me how to manually download and install the firmware (which is already running!) and if this didn’t solve my problem then just stop using WD Access…!