Wd mycloud dead data recovery PLEASE HELP

So mycloud wd started solid red light and did not work with whatever I tried, I opened it and connected it it with SATA BOX and cable to both windows and mac, but in mac it says “the disk you inserted is not supported “ and in windows I tried linux reader and it says “unallcated”. Anyone knows how to fix? PLEASE HELP as I have unreplaceable photos and videos in it.
Thank you.

Use the forum search feature, magnifying glass icon upper right, if you haven’t already. There are a number of past discussions on how to try and recover data from a My Cloud drive that can no longer be properly accessed while in the My Cloud enclosure.

https://community.wd.com/search?q=recover%20data%20category%3A105%20order%3Alatest

One such discusison:

WD has a page on data recovery:

https://support.wdc.com/warranty/datarecovery.aspx

I tried the method you have referenced, paragon didn’t solve. Linux reader
didn’t solve, fuse didn’t help, ntfs to mac didn’t work, estf didnt work. I
am just lost with using everything. One thing I have not tried is using
linux os. Because I don’t know how to install linux with windows 7 without
usb or burning cd. Does anyone have a link to the set up of linux
installation app for windows 7 without usb and cd burning?

Linux is a OS that if one doesn’t install properly will replace their existing operating system. One could try to dual boot Windows and Linux. It is typically a choice when installing Linux to one’s hard drive. Use any Linux distro and it should give the option to dual boot. Ubuntu (https://www.ubuntu.com/) is one such popular Linux OS that should provide the option to dual boot.

https://www.tecmint.com/install-ubuntu-16-04-alongside-with-windows-10-or-8-in-dual-boot/

Chances are good however that if Windows does not even recognize, in the disk management section of Windows Computer Management, the hard drive when attached to the Windows computer and the drive isn’t recognized using the Paragon software or on a Mac or Linux OS computer then it is probably bad/dead.

If this is the case one’s only recourse may be sending the drive off to a professional recovery service. They are, however, typically very expensive and not always successful in recovering data intact.

I assume you did not have a Safepoint or Backup running on the My Cloud to backup the My Cloud to an external USB hard drive attached to the My Cloud’s USB port? If you did you could recover some or all of the data from that backup.

Thank you for your reply, Ibwas able to install linux OS today (my windows 7 is replaced unfortunately even though I selected the dual option). So I was very happy after successfully installing linux but when I plugged the sata cable of the wd mycloud hard drive, I couldn’t see the drive. It is very frustrating as I could see the drive in windows using linux reader but the actual linux OS cannot read?
So my question is, in order for me to be able to access the external hard drive via linus os, now do I need additional software or apps installed in the linux? Or the Linux itself should be able to open it? Apparently it didn’t open itself. Any apps or third party softwares you could recommend?
Thank you.

You may have to “mount” the drive in Linux if it doesn’t automatically mount the drive. Do an internet search for how to mount a drive using Linux.

It is very possible the drive is bad and is only being seen intermediately by the OS.