WD MyCloud as a media server through a Samsung Blu-Ray

I have been trying to set up my WD MyCloud as a media server through a Samsung Blu-Ray DLNA compatible device.
I have set the WD MyCloud to work as a DLNA server, and iTunes server.
The Samsung Blu-Ray recognizes the WD MyCloud and shows some of the videos, but not all of them (maybe about 30% of the videos).
The videos that the Samsung Blu-Ray does recognize, play perfectly.

How do I get all of the videos to appear?

Details:

  • The videos are located on the WD MyCloud in the Public folder.
  • The videos are all .mp4, or .m4v format (mostly .mp4)
  • All of the videos were made with the same software, the later videos are higher resolution, however there seems to be no correlation as to which videos appear - it appears to be a random selection of videos available.
  • The largest video file is about 3.5 GB
  • I have “Rescanned” and “Rebuilt” the WD MyCloud DLNA Database several times

Hardware:

WD MyCloud, 4TB, P/N: WDBCTL0040HWT-00
Recently updated to the latest firmware (yesterday)

Samsung Blu-Ray, Model BD-JM57C/ZA, Software Version: B-JM53BSPWWB-1012.0

[quote=“jgreg7, post:1, topic:209411, full:true”]

  • All of the videos were made with the same software, the later videos are higher resolution, however there seems to be no correlation as to which videos appear - it appears to be a random selection of videos available.[/quote]
    What software was used to create the MP4 or M4V video? Have you tried using a different program (like Handbrake - https://handbrake.fr/) to reencode those video’s that don’t play properly?

Have you checked the Samsung BlueRay player and updated it to the latest firmware? What about the app on the player used to play the media, is there a way to update it as well?

Double check, through the My Cloud Dashboard, that all of the media files are in a Share with Media Serving enabled.

Thank you for your response.

The software used to create the files is Wondershare Video Converter. The files were originally AVI and re-encoded to MP4 format. (Some of the older files were M4V to be compatible with IOS before it would read MP4)

The Samsung Blu-Ray has the latest firmware, and the app that plays the video is built into the “Smart” dashboard.

All of the files are in a Public folder, and media serving is enabled.

I will try the handbrake re-encoding to see if it works any better - i will re-post the results.

I re-encoded several files from the original AVI format to MP4 using handbrake. Several of these had much smaller file size. I also encoded several with the MPG format.
NONE of these new files are visible in the listing.

Any other ideas?

Go to the Twonky User interface (port 9000 of your MyCloud IP address, e.g. 192.168.1.32:9000). Use the media browser built-in to the Twonky UI to see what Twonky thinks it has found. This will tell you whether it’s a problem of Twonky not recognising the media format, or your Blu-Ray player not displaying the media file for some reason. Twonky will only show media that the DLNA client says it can understand. So if your player isn’t declaring that correctly, or Twonky hasn’t detected the client type correctly (or the client type info is incorrect), then your player may not present all the files.

You will find some pointers to setting the Media Receiver type, and other aspects of Twonky operation here:

1 Like

In addition to what Cpt_paranoia indicated, as a troubleshooting step try using another computer/mobile device or similar that has DLNA client streaming support and see if the problem can be replicated on a different device.

Thank you for your suggestion.
I downloaded “8player” on my iphone, and it does seem to show all of the videos, and every one I played works fine.
So… now the problem seems to be getting this to work with a Samsung Smart Blu-Ray player.
The Samsung Smart Blu-Ray player has a DLNA built-in, however there are now user settings available. The firmware is the latest version, and the player is less than a year old.
Is there a list of compatible devices?

No. There is no official list of comparable devices (that I know of or seen posted here) with respect to what DLNA clients Twonky supports. Perhaps see the Twonky website (http://twonky.com/) and check if there is a supported DLNA client listing. See Cpt_paranoia’s post above mine to check what Twonky is listing for your Samsung BlueRay player in the Twonky administration section.

It seems there are a fair number of complaints with Samsung products not working properly with the My Cloud/Twonky if one does a subforum search (magnifying glass icon upper right). If you haven’t already you may want to check Samsung Support to see if there is any solution or if they have a support forum since this appears to be confined to the Samsung Blu-Ray player and other DLNA clients.

I went through the listing for Cpt_paranoia’s post, with essentially no changes in the result. It seems that I can only see about 20% of the videos.

I have re-encoded a couple of test videos in several different formats, and file sizes, however I just cannot seem to make these show up. There seems to be no clear reason why some show up and others do not.

Samsung was mostly a dead-end….
I contacted Samsung, and their rather cryptic response was that they were “aware of the compatibility issue”. However, they did not offer any further path forward.

I followed this up with a phone call to Samsung Tech support (which is not really much support), the agent had to look up “DLNA” to see what I was talking about. She offered me no solution other than sending in the device for servicing. She was also unable to escalate the issue.

It seems that, if I want to use with MyCloud as a media server, I will need to find another model of playing device. It would be helpful if WD issued a compatibility list.

One suggestion that I don’t know if its been suggested yet. Use a metadata tagger program to examine the various files that are not seen/played by teh Samsung player to see if perhaps there is a problem with the media metadata. Try removing all the metadata (if any) from the suspect media files as a troubleshooting test. Also make sure the media file names are not long and don’t contain any special characters. Try changing the file name to something else to see if the error persists.

Or it would be helpful if Samsung issued a comparability list of media servers that work without issue with their device…

1 Like

Following up on this issue, after several months of chasing this, I finally got through to somebody in Samsung that actually understood the problem AND spoke English (will wonders never cease).

Apparently, Samsung engineering is aware of this issue, but does not consider it to be sufficiently prevalent to actually create a solution. Also, they do not seem to have any specific plans to include this functionality in new versions of their equipment.

Their focus (as it was generally explained) for Blu-Ray players seems to be on streaming media and Blu-Ray disks. The DLNA they provide is a sideline that “meets the DLNA standards…”.

So… in the absence of reliable interface information as to what works and what does not, I am chalking this media server idea up to a general waste of time, since the DLNA standard does not seem to provide a reliable connection. It is a shame, it seemed like such a great solution.

My WD My Cloud will be re-tasked as a general back up drive.

1 Like

It works just fine for a huge range of other DLNA clients and renderers.

You just happened to buy a device that, by the manufacturer’s own admission, doesn’t work, and they can’t be bothered to make work.

Get a better DLNA client/renderer device. Anything other than Samsung.

How is the DLNA standard not providing a reliable connection? Your post states that Samsung is aware of the issue but has chosen not to do anything to remedy the problem with their products (Smart TV’s included) that have trouble properly access a DLNA media server on an NAS like the My Cloud.

If you want to stream media to your TV there are a number of other devices one can use. Some use an inexpensive Android devices, load Kodi, and stream from the My Cloud. Others use devices like the Roku to stream media from the My Cloud.

1 Like

On June 24th, in this forum, I asked if there was a list of compatible devices. I was told there is no such list. I am not committed to the Samsung device, but when I asked, there were no recommendations for an alternative. I found several Phone apps that stream nicely, however I don’t want to watch videos on my phone.

Apparently, the DLNA standard is not applied uniformly. Can you imaging purchasing a USB Thumb Drive and finiding out is does not work with your computer?

If there is a reliable device that I can purchase and connect to the TV, that is known to work with a Samsung TV and the WD My Cloud, I would like to hear about it. I just cannot afford to keep purchasing and testing devices that do not work.

It simply should not be this difficult to get something to work properly.

Any one of the hundreds of plain vanilla android media boxes you can buy for about $30-40, and install something like Kodi, and access the MyCloud using SMB. Or DLNA if you really must. Connect the media box to your TV via HDMI. Use one of the many android DLNA music player apps if you want to play music, e.g. BubbleUPnP. Install whatever streaming media service or catch-up TV apps.

Plain vanilla android boxes have access to the entire Play store, not just the tiny few that a ‘smart tv’ manufacturer deigns to provide (that, as you have found, may not even work).

I imagine I would have googled for reviews and comments about the Thumb drive…

WD apparently doesn’t maintain a list of devices compatible with the My Cloud. Don’t know if Samsung does either (I would guess not). Note that we are end users of the My Cloud such as yourself, not WD employees.

It is the manufacturers who are at fault here. In certain cases they are aware of various issues but choose NOT to do anything about it. Yes I have purchased a USB thumb drive that didn’t work with certain computers. I’ve purchased many SD and microSD cards over the years that were hit or miss on working with certain devices like cellphones. Its a fact of life that not everything will work 100% when it comes to interoperatiblity between computer hardware, software, and devices even though they are supposed to conform to certain standards like DLNA. One can view the DLNA certification site (https://spirespark.com/dlna/products/) to find out if their product (or product line) is DLNA certified.

The My Cloud itself is an example of this. The My Cloud has a USB 3.0 port. Yet many have discovered that they cannot achieve the transfer speeds to external USB 3.0 hard drives that the USB 3.0 specifications indicate.

There are numerous devices; from cheap Android boxes running Kodi, low cost home theater PC’s running Kodi or Plex, to Roku’s, to Apple TV, Amazon Fire sticks that can stream media from NAS devices like the My Cloud to a TV or SmartTV.

No it shouldn’t be “this” difficult to get the Samsung BluRay player to work with the My Cloud but it is, as evidenced by many past discussions in this subforum on Samsung products. Samsung is apparently aware of the issue but chooses not to fix their product(s) or inform their users/customers there may be an issue with certain NAS devices.

WD isn’t the only NAS manufacturer that certain Samsung devices have trouble with. An internet search for Samsung + Synology will turn up a number of complains about Samsung products having problems streaming from that manufacturer’s NAS devices as well.

1 Like

Hello I have a mycloud and I am able to connect it as a media server using my Samsung blue ray player model 6700. I had to purchase a mycloud home because I assume the myclouds are obsolete, but it doesn’t show up under the media server options on my blue ray. I thought this mycloud home was suppose to be an upgrade but it seems the mycloud was much simpler. the only reason I need the storage is store and view my dvd’s, if i can’t make this work the mycloud home is useless. Any help would be greatly appreciated.

It very much isn’t.

You will need to enable the Plex media server. You will find more experience on the appropriate forum:

Thank you, I enabled the plex media server, moved all my movies to it, and refreshed the server list on the blue ray play, but still no access.

Did you enable the DLNA server on Plex?