WD MyCloud 4TB - Cannot connect, shares not showing

I’m relatively confident that this is in some way related to the firmware, but I’m not 100% sure.

These are the details:

My Cloud 4TB

Firmware: 4.01.02-417 (released 12/17/2014)

OS: Yosemite 10.10.1


  1. The UI interface is moving extremely slow. The drive details only show intermittently on the home page.

  2. The shares are no longer visible on my network (browsing via the Finder) - connection failed.

  3. The WD My Cloud software will not connect to the drive

  4. These failures seem to conincide with the release date (12/17) of the firmware.

What I’ve tried:

I can connect to the drive via SSH and FTP and I can see all of my files - so that’s a relief. But as I said above, I’m not able to use the drive as I had set it up. SSH and FTP do not help when it’s being used as a normal network drive by my family.

I also tried creating a new share, and got the message which is addressed here "Share function failed 400099 (which was never resolved by WD support):  http://community.wd.com/t5/WD-My-Cloud/Share-function-failed-400099/td-p/680885

I’ve been perfectly happy with the drive up until this moment. I do not like feeling like it’s a risk for me to save files to this drive. I would like to have this issue addressed by WD Support ASAP.

Hi vaughn-taylor, welcome to the WD Community. Have you tried some simple troubleshooting steps, like doing a power cycle or connecting the My Cloud directly to the PC?