WD MyCloud (2TB) does not work across Domain

I recently purchased a WD MyCloud (2TB) storage device and it works fine with my home network.  However, I also have a work laptop that I want to backup.  It is part of my companies Domain and not part of my home group.  WD’s level 2 support [Deleted] has stated to me that i need a much more expensive device to accomplish this.  That is a false statement.  I just replace my Lacie 2 TB Networkspace device (after 4 years) with this WD MyCloud device and two years ago it cost me $199 and it allowed my work laptop to attach to it and thus worked perfectly.  I am extremely disappointed in WD that they are >5 years behind in this technology.  I would like to return my WD MyCloud so I can go back to Lacie.

I can access the NAS with computers that use enterprise domain and home workgroup. What didn’t work with your work computer exactly?

1 Like
  • I can see the MyCloud device and shares
  • I can read from them
  • I can even delete files from there


  • I cannot open a file and save it back
  • I cannot copy a file to a share

I can do this If I am on a different network and use the Cloud connection.  Just seems like the level 2 support guy was clueless and gave me a [Deleted] answer.

On both computers:

  • are you accessing the NAS through a drive mapped to a share? or through wd2go.com? or through the wdmycloud app?

  • are you using the same OS?

  • are you trying for the same file across computers?

  • does it depend on the type of file?

First, thank you so very much for you assistance.  I greatly appreciate it.

  • I am access from both computers via a mapped drive to the same share(s) - occurs on both of my shares.
  • Similar OS, Windows 7, one has home edition other is enterprise
  • Copying, assessing, saving same file(s)
  • Word, txt files, excel, all fail.

The fact that you can delete files but not modify them is very weird because this kind of distinction would be at the share level, and the default rights on this NAS don’t allow you this distinction.

Can you confirm you can delete files on both computers, but not open, modify and save them?

That is correct.  On my home laptop, I can read, write, modify, no issue.  On my work laptop, I can read, but not write or modigy, but I can delete.  I also discovered I can copy from the drive and paste, it was a 1k file, but it did work.

When you right click on the network connection and select “open networking and sharing center”, a window pop up. What is the type of network you have there? Private, Public, or Work? Is it the same setting on both computers?

It shows Home network on both.  However, the Home Laptop is connected via ethernet cable and the work computer is wireless.  I have a verison Actiontec router. The level 2 support guy said they sometimes have issues with their settings.

Sorry, that was a Verizon actiontec router.

When you connect the work computer with Ethernet, does the problem subsists?

I did another test and created a 1K txt file and was able to copy it and edit it on the share.  If I try to copy even a 30Kb file, i get a network timeout.  So, this may not be related to permissions or credentials.  I have another mapped drive from my work laptop to my personal laptop and I can copy and edit larger files on that share from my work computer without a problem.  So, it is the combinatio of the work laptop and the MyCloud share that cause the network timeout.

Sorry, just saw your prior post.  I do not have an ethernet connection on the work laptop.

Just to make sure, you create mapped drives directly from Windows explorer, not through wd2go.com or anything, right?

Also, you are not using a virtual machine or something like that, right?

You are correct on both points.

I just bought a USB to Ethernet connector, plugged it in, turned off the wireless network adaptor and confirmed I had network and internet access.  I then tried to copy files and got the same results.