WD MyBookWorld won't boot up


I have a Mybookword Network backup device and I need to restore some lost data.

But I found the device was not connected to the network, I connected it and noticed only the bottom LED is on, after reading the documentation this I found is supposed to go off after three mins.

Any Ideas?

I don’t want to factory default it, I need the data that is on there.


Hi there, do you have a Worl or a World II? If you have a World 2 on RAID 1 then you could take one drive out and read the files on Linux Fedora Core 14 Live CD, if you have the single drive World, then you may have to break the warranty to recover the data using the same method.

Hi - did you get any helpful response on this? I have the same issue - the drive worked yesterday and this morning was not working. Only the bottom led light is on and it just stays like that. Not appearing on Network - I have tried the basic reset settings, but as it’s not appearing as an attached device on my router or direct into the PC I really don’t know what to do. Does this mean it’s buggered?



For info it’s a 1TB MBW White Light.

WD Discovery is on the PC, as is Windows 7.

It’s been all good so far until today when it seems to be dead :frowning: Most of the Data’s Backed up, but I don’t want to just throw the hardware away, it’s not cheap!!!