WD Mybook with ethernet interface partial failure

MyBook 2TB partial failure

I’ve been satisfactorily using an WD Mybook with ethernet interface for some weeks. Now I’ve got the trouble described hereby:

  1. the green led is flashing indefinitely and never stops.

  2. the HD can be used for storing and retrieving files, but listing the files with windows the time marker field remains empty, while listing the files by DOS prompt the date shown is 1970.

  3. cannot get connected via internet browser (Microsoft ie): the disk ip address is pingable on the lan, but the browser shows that the URL is unreachable: i.e. cannot run the management page and check the current settings and conditions.

Can I kindly ask for info/suggestions to the community.

Many thanks in advance.



I’d say you have a MBL…

1- The green LED will keep flashing for activity for as long as there is ANY activity, which can be LAN access, remote access, NTP updates and/or media serving.

2- I don’t understand this point.

3- You mean accessing the configuration page or doing FTP? Because IE is not good for FTP and I’d suggest using a client for that, if you mean you can’t access the configuration page then try another browser or try with the device name instead of the IP address while making sure the MBL is on the same WORKGROUP as your computer.

Thank for your kind reply.

  1. The green led flashes continuously, even though all PCs are switched off and the ADSL cable to the router is disconnected.  There is nothing operating on the network.

  2. I can save files on the disk, using “copy and paste” and ftp as well. However, the “date modified” property of the files is not visible (empty cell) when listed into the windows directory view; I mean, when you double click the directory icon and the disk content is shown in the “show details” mode. If I list the files in a command prompr DOS window, the shown date is always 1/1/1970.

  3. FTP is working; I can copy files using Filezilla ftp client SW. What is not working (anymore, because it has been working for some weeks) is accessing the configuration page by browser. The problem is not, in this case, the IP address, since i can ping the disk and I can access the disk for file copy and retreiving on the lan by ftp and “copy and paste”.

My LAN serves four PCs and an WD-TV live. The router is an Huawei with wireless, four ethernet swict ports and ADSL WAN port (PPPoE). The IP subnet is and the IP addresses of the peripheral devices (disks, PCs, WD-TV) are assigned by DHCP reservation (and so, always the same address to the same device). The WD MyBook disk is connected to one of the router switch ports: another of such ports is used for connecting the WD-TV live and a third port is for a Desktop: on the wireless, there are only three laptops. Another HD-NAS (Packard Bell) is connected to a SAMBA server USB port on the router.

Everithing has been working fine for more than one year: the WD-Mybook disk has been installed a couple of months ago, and has been properly (and satisfacorily) working 'till one-week/ten days ago.

Thanks again, ThePizzaMatrix. Hope these detaqils clarification can help to better understand.


One thing that has not been mentioned.  Have you powered-down your MBL, counted to 10 and then powered it up?  The reset button on the back only resets the networking paremeters to DHCP, blanks the owner password, resets the root password and reboots the MBL.

Try a reset with the button first.  If that does not work, pull the power plug, let it settle and then plug it back in.

I tried to:

  1. disconnect ethernet cable for two minutes (the led changed to flashing green to steady red) and then connect it again (normal startup, with led changing to blue red, yellow, green, green flashing again).

  2. follow the shut down procedure given in the manual:

   a) disconnect ethernet cable and wait for the led to change to steady red

   b) disconnect power and wait (three to four minutes);

   c) reconnect power (normal startup, with led changing to blue yellow red);

   d reconnect ethernet cable (led turning from red to yellow, green, green flashing again).

No success.

I haven’t tried to reset the device by pushbutton, since I noticed on the handbook that such button only acts on some security settings, and not on “HW”.