WD MyBook Studio Edition II icon NOT appearing on Mac OS 10.6.8

I recently shot a film and am using a 4TB WD MyBook Studio Edition II to save as I edit on Adobe Premiere. Several times an error has popped up stating the disk wasn’t ejected properly, however nothing was ever disconnected. The same thing happened today, only this time when I shut everything down and turn it on again, the WD ICON did not reappear on the Desktop. After 3 hours of reading, unplugging, restarting and reinstalling software the icon will still not appear. I have checked Disk Utility and tried various USB cables as well as electrical outlets. 

I would love to avoid having to make a long tech service call/visit if someone could advise how to proceed in troubleshooting this issue! Thank you in advance! 

there used to be an issue with macs continuing to supply power to the external drives, whether through firewire or usb, after they were turned off.  this would cause the drives to think they were still connected even after the mac disconnected from the drive.  then the mac wouldn’t see the drive when it was turned back on.  I think the same happened when the mac would go to sleep.  I don’t know if that’s it or not. but if you turn off the mac, you may need to disconnect the drive as well.

did it show up in disk utility?  I would turn off the mac, disconnect the drive, turn on the mac, then reconnect the drive after the os is up and running.  does it show up then.

   Thank you for the reply. I have had the issue of the external drive ‘ejecting’ when the computer goes to sleep and getting the same error sometimes after I disconnected the HD ‘properly’. I had to take a computer break because I have shut down and restarted my computer and external drive more times than I probably should have without any success… I resorted in calling tech support and they were not able to help other than having me mail in the broken HD and they will replace it with a new one. They suggested data recovery for the files I lost, which is not necessarily what I’d like to hear considering I’ve not been using this hard drive long at all, but of course what’s on there took forever to edit!

    Going to try one last time in the morning and if no luck, I will go by Best Buy and see the Geek Squad tomorrow and hope they can figure something out before shipping this one out. 

    If you think of any other solutions that may work, let me know! Thank you!!!