WD MyBook Live Duo: Reset *software* to factory defaults


I am owner of a new WD MyBook Live Duo 6TB since about one week - and happily recognized, that there is a debian system behind the scenes that can be used via ssh :-).

Well, in my old habbit in using debian (since 2.2 potato) I accidently did an “apt-get upgrade” on the system. This was maybe not the best idea… Everything went fine until apt-get came to the installation of samba-common and apache2-common, where it stated that some config files are also part of the package “wd-nas” and that the upgrade cannot continue.

So, I recognized that “apt-get upgrade” is not a good idea and tried to restore the MBL to factory defaults. After the machine was up again, I saw that the system was not reinstalled! So, obviously the hard drives are formatted and you loose all your data, hostname, passwords, users etc. are reset - but the state of the installed packages is the same as before (??).

Anyway, to finally fix apt-get, I changed to /var/cache/apt/archives and installed samba-common and apache2-common via dpkg --force-overwrite -i. While they were installing, I got asked what to do with the config files mentioned before, namely whether the package maintainers version should be installed or the old ones should be kept. For sure I did a backup of all these files or said “no overwriting, keep existing ones”. After that, I run the rest of the upgrade, got asked several times what to do with existing config files, said always that they should *not* be overwritten (or made a backup) and the upgrade went smoothly to it’s end. Now, apt is usable again and my system appears to be at the latest lenny state (at least to tell from the sources in /etc/apt/sources.list, which I did not modify… also I haven’t commented out the squeeze repository)

The end of the story is now, that everything works as before, no performance drawback, no issues with the web interface, everything is fine. Except one thing: the MBL refuses to go to sleep. I know that this is not a support issue any more, with my modifications to the system…BUT: if I had the dpkg packages of the original system, I could reinstall them using apt/dpkg and eventually the standby mode would afterwards also work again.

So here is my question: How can I restore the installed packages to the factory default using dpkg/apt? Is there a way to get the packages that have been installed when I bought the device, i.e. wd-nas and everything else?

Or is there another possibility? The “Restore to factory defaults” entry in the web administration interface does obviously not what is needed…

If the standby issue could be fixed otherwise, without a system downgrade, this would also be great or even better ;-).

Thanks in advance


I just want to let you know that, after my last “restore to factory defaults” via the webinterface, it seems to work now… the MBL slept when I came home today :-).

It seems to me that there is something wrong with the media server. I had my music stored in the “Public/Shared Music” folder all the time and now there is no music any more. But I don’t have any DLNA devices connecting to it, so this is weird.

And there is still the question, why WD does not provide a repository with their debian packages in “/etc/apt/sources.list” ? Is there such a repository at all? It could/should be the complete factory default distribution, as you get it when you buy the device, so that you can always revert to this software if something goes wrong…

Best Regards