WD MyBook Live 3TB: Error Code 0x80004005

I’ve had issues with my WD MyBook Live 3TB that has remained unresolved.

At this point I would gladly settle for recovering the files off of the drive and retiring it.

  • This harddrive connects via my home network.
  • Shows a green status light on the front.
  • Shows up in Windows Explorer under the Network section as ‘ccnaserv’
  • When I click it’s icon under Network it opens up my internet browser and takes me to the WD UI page for this harddrive.
  • It shows 760GB of data used out of 3TB.
  • If I try to navigate to the drive in Windows Explorer by typing in \ccnaserv it takes a few moments but eventually gives me a message telling me to check my spelling of the file name and the error code 0x80004005
  • I’ve opened Command Prompt and run arp -a which did find the device that matches up with my Harddrive’s MAC address.
  • I tried going to that IP address in Windows Explorer and got the same results.
  • I’ve tried this on multiple computers, done the 4 second reset, and spoken with a very helpful WD Tech Support agent on the phone.

Any suggestions to fix this issue or any ways I can recover the data off of the harddrive would be greatly appreciated!

Thanks,

Zak

There are a few possibilities, see this link>>>>https://www.google.com/search?sxsrf=ALeKk02-wsB_6eXSCU4e4b2gVkQGNf8BQQ%3A1611269713563&source=hp&ei=UQYKYJCdH4mWsAWBqIvgAQ&q=network+drive+error+0x80004005&oq=network+drive+error+0x80004005&gs_lcp=CgZwc3ktYWIQA1DGBVjGBWCyD2gAcAB4AIABaYgBaZIBAzAuMZgBAKABAqABAaoBB2d3cy13aXo&sclient=psy-ab&ved=0ahUKEwjQiaW3j67uAhUJC6wKHQHUAhwQ4dUDCAk&uact=5