WD Mybook Live 2TB cant be found anymore =/


#1

My Mybook Live worked fine for 3 months connected to a netgear router. I’m using a mac OS 10.6.6 with it.

Yesterday my brother tried to add its contents to plex, was prompted to enter a password, failed, and now the drive is gone from the network, and I can’t get it to do anything.

The lamp on the front is a green steady light. The network lamps are green and blinking. It makes sounds so something is working. I’m pretty sure I named the drive something other than “mybooklive” but I can’t remember what so that might complicate trying to connect to it, I don’t know.

I tried varous ip addresses and connecting to //mybooklive/ui/ both with the drive connected to the router and directly to the computer, but to no avail

I have tried resetting it (holding the reset button 60s w/o power and then a further 60s with power) but it still can’t be found. I tried reinstalling the smartware on the mac but it still cant find the drive. I also tried restarting everything, and I moved around the cables on the router. Still – dead.

Is there a way to find the drive a again like by resetting it? I don’t particularly care about the contents.


#2

k I have som new info: apparently there were no passwords involved, the drive  just dissapeared when he tried to add it (and now I obv. can’t find it).

I guess that means the whole thing is dead?