WD MyBook External 1.0TB HDD (WD10EADX) - No longer spinning after using wrong power adapter

Hi All Experts,

I’ve read some of the similar incident in this community whereby I’ve accidently used the laptop power adapter instead of the HDD power adapter and then my HDD no longer have any lights or disc spinning activities.

By then, I knew I must have blown something on the circuit board.

My next action then was to take out the HDD, removed the circuit board connected to the HDD, and connect the HDD to my computer directly by using some external SATA-to-USB devices.

Unfortunately, that doesn’t help. When I plugged in the power cord into the power socket and turn on the power, the power indication just keep flashing on the SATA-to-USB device but the HDD remained static.

I tried on other HDD and it power up just fine.

Does that means I’ve blown the fuse or something not only on the external circuit board but also on my HDD circuit board?

I’ve read some solution provided is to replace the fuse to get it working again so I’m attaching a pic of the circuit board, hoping some kind soul can help me now.

I’m not much of an electrical person but I really need to get into the data as it contains much of my work document and personal family photo. :cry:

Please help…

Search they posts by fzabkar he has helped other people with this problem. He explains about finding and by passing the burnt doide. You can also try a PM to him.


1 Like

Thanks Joe!

I have tried searching his posts but found nothing on passing the burnt doide.

Can u point me to that discussion?

And I’ve pm him.

Thanks for your prompt help!!

Hi All,

My issue has been solved as helped by this fabulous person called fzabkar (and many thanks to Joe_S for pointing me to the right person too).

My solution is to remove the 12V TVS diode (D4) from the PCB.

He also shared a few useful links, which I will share here to help future victims


However, I still have issue with accessing the HDD now as it is no longer recognisable after being detected.

I’m still working with fzabkar to solve it.

Glad he was able to help. He’s the only one who understands much about the boards.


1 Like

Hi All again,

Following up from my last post, I was able to get the HDD to power up again.

And then when I tried to connect it to my laptop, it became unrecognisable.

fzabkar have then advised me to re-attached the original bridge board that comes with the HDD because the board will help to decrypte the content inside.

I did that now and it has all seems well except that it is now not having any response at all when I plugged into my laptop.

The laptop powered up as per normal, (no clicking or weird sounds as per normal) and I can hear the normal disks spinning sounds as always.

The thing is there is nothing showing up on my laptop, nothing in My Computer, disk management, device manager and whatsoever. It’s like I have not plug in anything.

Any help / advice will be much appreciated!