WD MyBook Essential powers on, but drive is silent, won't appear in Windows

I was using my Western Digital MyBook Essential 2TB external HDD, all of a sudden it disappeared in Windows. I tried unplugging and plugging it back in, but it didn’t help. Tried restarting the PC, didn’t help either. The light on the drive came on as normal. The drive is not visible in Disk Management.
I then realized the drive was totally silent. I tried with a different power adapter (I have a total of six of these WD Element external HDDs), same problem. Also tried a different USB cord, even though obviously that wouldn’t
help but just so I could say I have tried that. I tried it on two different computers too, each with different operating systems (one of the PCs has Windows 7 and the other has Windows Vista).
Btw, I am plugging the harddrive directly into the PC’s USB port without any USB extension cords, and while the AC adapter normally goes into a “power strip” thing with 8 outlets, I have now tried it directly to the wall
socket to no avail.It seems the power is fine, I think the drive itself is the problem. Could there be some kind of connection between the power supply and the drive that has somehow gotten “unhooked”?

I am quite upset now since this is the second time this happens to one
of these WD MyBook drives. I lost alot of data thanks to it. I do have
many WD Passport type drives as well, which powers up with USB power and don’t require AC power, and I’m very happy with all of those as none of
those drives have failed me so far. Makes me wonder if I should just copy the remaining WD Element drives’ contents to passport drives and get rid of the rest of my MyBook drives, because this makes me very concerned my data may not be safe on them.

Anyway, please, if you have any suggestions what I could try to access my drive, tell me. My priority is to just connect the drive long enough to get the contents off and onto some other storage, to save my files, I really don’t care about the HDD itself. Thank you so much for reading and for any assistance you can offer me.


You can try contacting WD Support for direct assistance on this case to see what else you can try.

WD Contact info:

I did… But all they said was to contact a data recovery lab to retrieve my data.