WD MyBook Essential 1 TB suddenly not detected on Windows or Mac OS


#1

Please help me.

I bought the thing 2 months ago and everything worked fine. I’ve put 750GB worth of files in there (my work, my photos, my movies, etc.) with no backup whatsoever (my bad there). Anyway, just yesterday, I was using it while browsing the internet. But something weird happened when I tried to move my downloaded data in there. Usually it would only take several seconds to get back from power saving mode, but that’s not what happened. It just freezes the system entirely, I can’t click on anything. I tried to remove it, but nothing happened. So out of desperation, I unplug it.

And when I turn it back on, the Smartware virtual CD loads, and the nothing happened. The drive just won’t load. And I notice that the capacity gauge doesn’t lit at all (the four bars were supposed to lit because I’ve used more than 3/4 of the total capacity). Anyway, the system froze on me again, apparently when trying to load the drive.

I panicked. And I can’t seem to remove the drive. So I unplug it again. I try to do the same thing for several times but it always ends up the same. Finally I decided to wait while it loads, and in about 5-10 minutes the capacity gauge lit entirely and my drive pops out. But the problem remains, I can’t seem to access it, because it still freezes my system.

And yeah, I’ve tried 3 different USB and power cables. I’ve also tried it on Mac OS and Windows 7, but nothing works.

Is there any solution to this? Anybody ever experienced anything like this? Please help. I simply can’t afford to lose my data.

Thank you.


#2

1.  Is the drive spinning?

2.  if yes, do you see the drive under system profiler under USB?

  1. if yes, what is the partition and format showing in Disk Utility?

#3

I have purchased three MyBook 1TB Drives over the past several years, every one has failed after 14 to 16 months of use.  Two of them I have disassembled the enclosures and turned them into internal drives to recover the data, the third one has just ceased working on the network.  Is there a fix to this issue, or do I need to toss another enclosure?


#4

Jon Weiss,

Can you use the latest 1 TB mybook as internal drive? It seems to build a virtual CD of 600 MB automatically that cannot be deleted…would this be due to electronics in the casing, or would it be due to some chip in the drive itself?

Any suggestions?

Also, can you point me to some reliable tutorial on how to disassemble the new 1 TB mybook? Thanks a lot.

I am totally disappointed with this new 1TB mybook. Very poor quality, it seems WD is trying to save money. The casing is of poor quality, the assembly is wobbly (it can tip over easily), it has no e-sata port, and it was packaged very cheaply.

I have so many failed internal WD drives…its all a mess…I bought the mybook hoping that it will be better, but your comment proves otherwise…

________________________


#5
  1. Yes, the drive’s spinning. And the Smartware Virtual CD also mount quickly like usual.

  2. If I waited for about 10 seconds (my system will freeze during the time), and then the partition mounts. But I still can’t access my files. On Mac OS, it shows that I have about >200 GB worth of free space.

  3. Disk Utility show the partition after several minutes, but I can’t do anything except moving my mouse (clicking isn’t working).  The partition is in NTFS format, I’ve used Paragon NTFS and NTFS 3G, and before this I’ve had no issue in working with an NTFS partition in Mac OS X environment. When I’m accessing the disk using Windows7, same thing happens (freezes), after about 10 minutes it shows up but I can do nothing. I’ve accessed it using Disk Management, and it shows “unallocated” partition.

I’ve read several threads in this forum and it seems a lot of people are having this issue. And so far, no solution.