WD MyBook 3TB. I would like to access it from www

I’m trying to set up my WD HD 3TB for remote access. From LAN it’s ok.
I’ve already done this steps:

  1. static IP address on LAN for HD (ok)
  2. enable and test ssh access (ok)
  3. port forwarding on netgear WNR1000v3 router(?)

I’ve had success accessing it from LAN using ssh by shell and by filezilla. I works perfectly. But is not my goal!
Port forwarding is the problem; I read this howto, but from the dashboard I can’t see “Connected. Port forwarding connection established”.

I see this error message “Connessione di inoltro alla porta non riuscita sulla porta 8080 e la porta 8443 . (Errore 31526)”.
Any suggestions would be great!

Thank you

Hello and welcome, 

Have you tried to setup the remote access account using WD2Go? You can check the steps on page 107 of the manual. 



1 Like

Thank you for your answer, but I’m looking for a different way to access it. I’ve already tried WD2Go for my smartphone and in my opinion It’s not very useful.

I would like to access it from a sftp client like filezilla becouse I have more than one operating system (windows and linux).

Any other ideas?


Those settings in the link you provided are ONLY for remote access using WD2GO apps. It has nothing to do with accessing it via SSH.

If you want to use SSH, well, you have to foward the SSH port to the MBL on your router.