WD MyBook 2TB external is not being detected any where

The drive was working fine till yesterday. Today however when i tried to connect to the drive, it simply wont get detected. Whenever I connect the drive the light wont automatically turn on, have to turn the drive on by using the switch located on the backside of the device. After pressing the power switch the HDD light flashes for about 5 seconds and then stays on. I can hear the drive spinning though. The drive isn’t listed anywhere neither in the device manager nor in the disk management. Western Digital Data LifeGuard Diagnostics Utility is also unable to list my WD drive. I have checked the drive on another PC as well, so I am sure its not just my computer. I have important data in the drive which I don’t want to lose at any cost. Any help in this matter will be highly appreciated.


Are you connecting the drive to a power strip? If so, connect the unit direct to the wall outlet. 

I have tried connecting it to the wall outlet as well, but no luck. Still the same issue.

I would like to know if the recovery of data is possible if I take the drive out and connect it via USB to SATA cable to my laptop. Is my MyBook Essential external HDD hardware encrypted? How do I find that out?

If you open the drive you void the warranty. Call customer service and see if they will send you a new power adapter. If this is a drive that came with Smartware then it will be hardware encrypted by the circuit board with the USB port. Even if you get the drive recognized the data will be encoded and useless.


 fzabkar helped me narrow down the issue to a faulty usb connection on the PCB of the drive. If that is the case I should be able to get it fixed and extract the data and then I am planning to dump the external case. Its a shame really, cause the drive is just 4 months old, but I really don’t have any other option.

I never bothered to check that this version of WD is hardware encrypting the data, which was my biggest mistake.

Thank you guys for helping me out.

P.S. - Moderator please close this thread.

I have the same problem and nothing solved it