WD MyBook 1300 1TG not working any more

before 2 days ago my WD Mybook 1 TG been attatched to my laptop until then, and today when i try to plugged it in again to store up some files again now it wont start working.


i bought it for about 2 monthes, been working fine until today;

i did not install the smartware that come with it, i plainly only use it as a backup storage drive;

the problem is, whenever i plugged it in my laptop, the driver show up in My computer or driver management or device mange windows, the autoplay window popup as well, but whenever i try to open the driver and then try to open any folder or file in the driver, it freezes up!( show as Not Respond in window tab) and if i wait for it to respond, the hard drive itself will just restarted.(the blue light turn off then turn on again in a few secs)it also freezes up my whole windows, which mean the explorer.exe froze until i unplug the driver;

I 've tried uninstall and reinstalling  the driver, tried plugged it in other computers and it still doing the same;

I also tried using the testdisk the check it, but it didnt find any problem, also when i chose the option the “deeper Search” since it has to scan 1.3 TB, which is gonna take more than a day so i cancel it in the middle.

PLEASE DO NOT tell me to reformated it, since there are 200ish GB files in there i dont wanna lose, not to mention when i do anything to the driver, including right click on it and check its property it also freezes up.

so please if any1 good enough help me fix this problem. ty!

Well dude, the drive sounds corrupted seems it’s doing it on other computers so there’s not much left to do other than formatting, one thing to note is that you DON’T have a backup since you can’t “lose those files”. A backup means having the data on at least 2 completely separate locations in case pone is to fail…