WD My Passport won't open in Computer

My WD My Passport won’t appear in My Computer. It is on the Device Manager and Disk Management. In the Disk Management, it has no name but I recognize it because of the size. The Disk Management says that it is healthy. However, when I right-click on the drive, the only option I can click is “Delete”, the rest cannot be clicked like “Open” or “Change drive letter.”

I don’t care about the files since I have a backup. But I want to use my WD My Passport EHD. I tried it with another computer and the same thing happens. What can I do? Thanks to those who will help.

1 Like

Hi kendricklamarx,

I would suggest you to refer the link below and follow the instructions to troubleshoot the issue.



Have you tried to run check disk command? If not then try it first, as it will help you to recognize and fix the hard drive issue.

Please let me know if this will not help you.

1 Like

same problem and not any solution:(((

my problem is different if i try to open mine it takes so long and it ends up force closing the file explorer