WD my passport (WDBBEP0010BBK-01) not opening

Hi guys,

I have a WD 1 TB my passport with model “WDBBEP0010BBK-01”. It is not working from past few days.

Problem:

After connecting to PC the drive is getting detected as “I: drive” i.e. drive letter is getting assigned but my laptop is unable to open it if I double to get inside.

As shown below the drive is there but like other devices it is not fully detected.

Data Life guard shows as below, so it does not detect the external HDD in physical drive:

wd_photo2.png

 CHKDSK stops here:

wd_photo3.png

I have already tried below trouble shooting:

  1. Connected the HDD to another PC but it is giving same problem.

  2. Tried USB cable from other WD HDD, but even then same problem.

  3. Tried “Data Lifeguard Diagnostic for Windows” but it is not detecting the HDD.

  4. If I open disk management, it is taking forever to detect this device.

  5. tried CHKDSK command also but it also fails to execute.

I have a lot of data in my HDD.

  • Kindly let me know how to recover my data?

  • Is there any other way I can correct the HDD without sending it for replacement?

regards,

Ayaz

Hi there,

I recommend Contacting support on this case for further assistance on this matter:
http://support.wdc.com/country/index.asp?lang=en%22