WD My Passport USB 500 Go - Disk not mounted - only usb device recognized


I have an issue with my “My Passport” USB disk. It is still under warranty.

Before I tried the replacement procedure I want to be sure I have any way to solve the problem on my own.

(cf Step 1 Please search our Knowledge base for possible solutions. why?)

Observation :

The problem is reproductible on any OS and computer I tried (XP, Ubuntu, Seven…).

On XP, with “Computer Manager”, I can see the device in “Device Manager \ Disk drives”.

However, the disk doesn’t appear in “Disk Management”.

Actually, I already tried several things from what I found on internet. But I didn’t find any solution.

I don’t really take care of the data. The only thing I want is to repear my drive!


If the drive is not on disk management, that means that the volume that allows the drive to be treated as a storage device has failed, try a firmware, a deep scan, another computer, a booster cable (USB cable that looks like the letter “Y”) and if none of that is to work… Then yes, replace it.