Wd my passport usb 3.0 external hard disk is not appearing on my computer

i have a wd my passport external hard disk 3.0 usb 1 tb, which is not appearing on my computer. I am using it from last one year and it was working good. I have all my data in it only. itz not fallen down or anything. suddenly one day it was working slowly and next day it was not appearing. other thing is when i am connecting it to my laptop or any other system then that system gets hanged. itz appearing in  safe removal option with its name ( my passport  0730). itz also coming in device manager. but when i am trying to open disk manager, disk manager window is not opening because of hanged system. itz appearing in my computer as local disk but not with its name and when i click on dat local disk again system gets hangd and message comes “my computer is not responding”. I calld wd customer care many time but got no solution. I have 900 GB data in it which i want back desperately. i tried different cables, different operating systems ( windows 7 and 8) and different systems also but same problem is occuring every time. kindly give me any solution (even if itz paid solution). Please…   thank you so much.

Hi I have had the same problem. when it does see a drive it trys to make me format it, did that on first one and same error after, took it back to currys and they changed it, new one does same.

I think/suspect that this is a problem with compatability of USB 3 to USB 2 not working properly.  This has been tried going through HUB and also direct into desktop.  Desktop is Sony Vaio VPCL 13S1E its got intel duo core, touch screen and is running windows 7.  unless get a result on this am going to take it back AGAIN and change to a USB 2 one or another connection.  

m16pab or Pete to friends.