WD my passport undetected

My passport 1 TB does’t show in my comuter, while connecting to USB the windows sound play, the driver SES is also present. WD smartware utily displaye no space in my passport. In :cry:management there is no alphabet for it.:heart:


You should try some basic troubleshooting:

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the PC, not through a hub).

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there.

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

I have tried all suggested solution. I am using laptop tried different USB ports, while connection windows sound is heard but it Disk Management and my computer it does’nt apperar at all. In WD Smartware  it shows my passport  but with message"No writable partition available" I know I have more than 450 MB space in my passport but it is totally blank only the Icon showing my passport.