WD My Passport Ultra - Not showing in windows explorer

I have a WD My Passport Ultra and when I plug it into Windows it doesn’t show the drive letter.

Disk management and partition magic say there are 3 partitions on the drive

  1. 1862.93GB (Active, Primary Part) Partition ID 0xa2 file system ‘other’
  2. 47MB (Primary Part) PID 0xa2 FS Ext3
  3. 9Mb Unallocated PID 0x0 FS unallocated.

None of these Partitions are mountable in Windows.

I’ve tried using recover partitions in partition wizard and it can see the two created partitions but it doesn’t know what to do with the large almost 2TB partition.

Does anyone know what I can do to recover the data from the HDD?

Device manager shows everything is OK with the drive.

Disk Management doesn’t give me an option to assign a drive letter, all the options are greyed out, the only option I can choose is to delete the partition.

I’m suspecting the Partition ID got messed up and shouldn’t be 0xa2 but I don’t want to change anything an mess up the drive and lose the data.

I’ve also tried R-studio which can see some files on the HDD but when i use the restore function lots of the files are just 0 in size.

I don’t know what the large partition was originally created as.

Has this drive ever successfully been used before in Windows?

I ask as the second partition is ext3, which is a Linux drive format which by default Windows can’t read. If it was set up on a Mac or Linux system then out of the box Windows can’t understand it.

There are various programs and apps which can allow Windows to view Linux type formats. See the link below for some examples, but a quick search for “open linux partitions in windows” will give you plenty of other options (this was just the first one on the list):

Try one of those and see if it helps.

It has only been used on Windows systems before as far as I know

It might be worth installing one of those programs to see if it helps, as it can’t really do any more damage.

But if it’s only been used for Windows then it may be a corrupt partition, which could be tricky to save unfortunately (if it’s possible at all). I’d just be curious as to what that ext3 partition is and where it came from.

Here is the latest update. I used a copy of Power Data Recovery I had from while ago. PDR discovered all the files (and some deleted ones) as a lost NTFS partition. I was able to extract all the files on the second run (although the first time it ran it just recreated all the files as garbage).

I believe this was case of a corrupt partition ID and this led to losing the File System. I was not able to get the File system back into working order but was able to recover 100% of the content on the drive using a data recovery tool.

Since the cause of the corruption is unknown I am now reluctant to ever use this drive again and it will be sent for recycling.

It’s likely something like unplugging/disconnecting it before it had finished writing to the partition and you got unlucky. But in any case it’s always recommended to keep backup copies of any critical files that may be stored on any drive, be it external or internal.

Recycling the drive is a little extreme perhaps, but it’s your choice. Glad you got all the data back anyway.

There could be various reason for any drive to become unresponsive or undetected. Here, I suggest you to check out the below blog to know the possible solutions for this issue: https://www.stellarinfo.com/blog/how-to-fix-not-responding-hard-drive/

Hope this will help.