WD My Passport Ultra not responding at all

Hello community !
I am recently dealing with a problem with My Passport Ultra 1TB. It was working fine normally but suddenly one day a notification popped up saying I had problem with my drive and asked to repair it. I did the same by going to properties of my drive. It was going fine but accidentally my PC turned off due to power cut.
Later I turned on the PC and when I attached my HDD back, the light are turned on (but doesn’t blink), the green icon of safely remove the device appears, and in My Computer its just displayed as Local Disk(F:) instead of showing the custom name I had renamed it to. When I try to open the drive the whole explorer gets freezed.
I tried to run the diagnostic tool from the WD website. When I plug my drive, the tool recognizes it and show the serial number, capacity and SMART with green tickmark but in no time the program itself stops responding.
Even tried to access the Disk Management but still the window keep on loading only.
Tried chkdsk F: /R and waited for hours but still no progress.
Once I plug my WD passport, it still appears in my computer though I plug it out. Moreover, any hardware change after that is not recognized unless I restart my PC.
I am in serious problem as I have important work files and pictures that I don’t have anywhere else.


How is the drive showing under disk management?

Its like this

You might want to try to scan the device with a good data recovery tool like R-Studio or UFS Explorer if you need to get your data back from the drive
PS: I’ve had really good results with both of these tools in the past