WD My Passport Ultra not recognized


My WD Passport Ultra started to have some issues a couple of days ago, I noticed that, for example, when I had it connected to my TV and my TV was in stand by he would do a “beep” sound but nothing too frequent. After I turned the TV on the “beep” stopped and the disk worked normally, so I didn’t worry about it. Unfortunately, the disk got worse and now it’s not recognized by the TV, PC and iMac.

When I connect it to the PC, the LED lights up and stays on without flashing, the PC recognizes that I connected a drive but nothing shows up on the Windows Explorer. After a minute or so, the disk does a “beep” sound of what it seems like a reset - the LED stays on and he does that “beep” (single “beep”) for about 3 times - all of them after a minute of it running. After that the disk goes into a stand by mode (the LED starts to blink very slow).

The disk is recognized in the BIOS and it also appears sometimes in the device manager under the disk drives and WD Smartware (where it shows the disk with a red “X” and 0 bytes). Another thing that sometimes happen is, if I boot my PC up with him connected, the PC gets stuck in the boot screen until I disconnect the external drive.

I have warranty, but the problem is that I have sensitive data in it that I don’t have anywhere else (stupid, I know) and I can’t afford sending it to a data recovery center.

The only anormal sound that the disk does is that sporadic “beep” that I mentioned, like if it was resetting itself, everything else sounds normal. I tried using my friends USB cable, from another Passport Ultra, but it didn’t solve the problem. Is there anything that I can do to regain access to my data?

Hello and welcome to the WD community.

We have passed this along to support, please check your private messages.

Thanks ArMak. I just want to give an update on this situation.

Today I’ve boot up my PC with the external drive connected and I noticed that it was reading but it was very very slow, so I went promptly to Windows Explorer, entered in the external drive directory and tried to copy what I needed from there. It took a while to count every file that I needed, but it did and then it started to copy but not long after that it gave me an error and I was not able to copy anything else.

So I went in to check the drive and I noticed that I wasn’t able to go inside the folders anymore. I tried a recovery software, didn’t help and then I updated the external drive firmware and did a reset to my PC - worried that I would lose access to it again - I did the reset, connected the drive and again, it shows up, but it reads very slow.

As of right now, I’m trying to copy what I need from there, but I’m not sure that I’ll have enough time to do it before I lose access to it again. :confused:


I have the same fault on my Hard Drive. 

I would be intertested to know what the Fault is. 

I have the same problem with the beep and 0 Bytes and Smart Failure.

I bought the Hard Drive from a computer shop as new. But, have a fault, the computer shop man refused to help, said I damaged it. But, I have done nothing to it. 

It seems like some ECU failure…

I have also seen a lot of these same faults listed on Ebay as faulty drives for sale. 

I have a few HD’s but never had a fault until now. 

I wonder if it is a bad batch of units. 

I tried entering the details on the RMA form, but it just says Error can’t complete. 

Currently awating a reply from Email Contact.