WD My Passport Ultra not recognized

My drive lights up and spins, but is not recognized. It doesn’t show up on my computer. It won’t read any info from it. I tried to assign a drive letter, but it doesn’t give me that option. It says it has a I/o device error. I just got this a few weeks ago, and am super disappointed :frowning:

Nat, I just brought one today from PC World…and guess what exactly the same…all lights up but file manager does not see it. Device manager does and the device driver says all is well… Tried a USB 2 cable thinking it ‘may’ be the supplied USB 3 cable… BTW my lappy does have a couple of USB 3 ports…

Bit pissed at the moment, wondering whether to take it back… I’ll see if I get any responce form WD… If not I’ll get a different drive…


I was contacted back and told to try a new cord, and if it doesn’t work than it’s defective. The whole worse part is I already put all my info onto it :frowning:

I had the same thing recently with a 2TB My Passport, though it’s a year old, but suddenlty wasn’t recognized by Win7 x64.  It would appear in the Remove area but not in Windows Explorer nor Disk Management.  Was unable to format it either.

However!  After trying a few sofware programs, I DID find that iCare Data Recovery was able to connect to it and I was able to see what was on the drive and recover it!

WD Suppor said to do up an RMA but when I tried online, it ‘failed’ and created a half-complete RMA and attempts to create a new one show no products registered, though it says mine is if I try to re-register or open a new Case File.

Oh well, guess I’ll have to go the old school route and call them…