WD my passport ultra 083A cant initialize

I purchased the external HD about a month ago, and loaded with my excess files from my 2TB. It worked fine up until two days ago. I let a friend borrow the drive to watch a movie, and when he returned it, it won’t work on my or his laptop anymore. My other hard drive works just fine in the same USB ports, I have tried all ports, I have tried flashing my BIOS, I have tried using programs like HD sentinel, I have tried to update the firmware and drivers (firmware update won’t even start,) I have tried unistalling drivers, rebooting, and let them reinstall as soon I plug it in. I have tried your Data Lifeguard tool, and it doesn’t even show there is one single sector to scan. The light blinks on the drive, but the drive does not spin, or at least feel or sound like it does. It shows up in safe removal and disk management. The disk is not initialized, and when I try to initialize it or turn it online, the error message "the request could not be performed because on an I/O device error. This goes for both MBR and GPT. Same error on all the laptops I have tried to plug into the past 2 days to fix it. Some help would really be appreciated.


Hello isuru3go,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support: