WD My passport SE Problem. Reformatted, but now can't be detected

OK, ill try to explain this step by step what I did and how I got to this problem.

My External drive obtained a USB virus that everytime I plug it in any device, it will make a shortcut which is an .Ink file. So far, that did not cause too much problems, yes it infected my computer but I can still use the External Drive properly. After that, I wanted to reformatt it, so i copied everything that was in it to my harddrive. Doing that manual back up, I reformatted the drive by going to My Computer  right click and formatting it there. 

Once I finished doing that I went off to work and plugged it in a MAC. Transferred very important files there worth around 20-25GB. Then when i got back home my PC detected it as Local Disk H. Now, knowing my pc had the virus, i tried other USB’s but it all worked, although it did the .Ink thing again, but still they were useable. Anyway, Im wondering why the MAC was able to open it by my PC cant? Im a really frustrated and worried right now. I tried downloading a Driver but still it didn’t work - while the External Drive was connected. It detects it, but it wont open it. Everytime i Plug it in, my PC recommend to reformat it. 

My solutions are.

Reformat, then use a recovery tool to get all my files - but will it get all of it?

Pls help. Thank you.

What file system did you use to format the Passport (NTFS, HFS+, FAT32, etc), and have you tried to connect the Passport to another Windows PC to check if the same problem happens? 

I choose NTFS since it was the only one on the list. Also, all the programs that came with my passport is now gone, before it had a quick reformat.exe file and other folders in it which came with the product, is there a way to get them back? Yes ive tried using it on other computer’s and it also read as drive H but cannot be opened. 

Since you want to use the Passport on Windows and Mac computers, NTFS will be read only when you plug it to your Mac, so you wont be able to add new files. You can try formatting the Passport again on your Mac and select the exFAT (read & write access for Mac and Windows) file system. Check the link below for the steps. 


You can also download all of the files that originally came bundled with your Passport from the link below.


Thank you sir, very much. Glad to know I can still use my harddrive.

The down side of FAT32 is the largest file it can handle is 4 gig. If that’s a problem post back there is software to use I don’t know if it’s still free.