WD My Passport Not Recognized On My Computer

Hey there,

So I have a problem with my “WD my passport” ( I believe it is 500gb)  not being recognized in my computer, thus unable to access the storage part of it. When I first got it, it worked perfectly. I then used it in a school’s Mac computer to do an audio project and it was unreconizable through the Mac computer. One of my peers did some sort of format to my WD passport on the mac to make it recognizable.  I completed my project and went back home to transfer my project to the laptop, however although it says in the device manager that it is recognized and the drivers are updated, It does not show up on the “My computer”.

Here are some info about my passport:

P/N: WDBKXH5000ABK - 01

S/N: [deleted]

4312B  R/N: C6B DAABEA

Some methods that I attempted

  • I copied and replaced usbstor.inf and usbstor.PNF files to C:\Windows\inf.

  • I uninstalled and automatically reinstalled the drives which forced my laptop ( windows 7 ) to restart 3 times.

Here are also some pictures with some info about the drive. I have no clue where to start or what to fix.

Hoping someone can analyze this and help me out on where to start. I went on several other forums to find answers but all their methods I’ve found ( like the usbstor.inf ) did not work or do anything.

 Thanks .  Please let me know what to do.

Well this forum is very helpful… mind my sarcasm.

Anyways, I figured out how to make it work again by formatting the drive.


( On a windows 7 )

  • Control Panel / System Security / Adminstrative Tools / Computer Management

  • Click on ‘disc management’ on the tab

[This part, my external drive showed up blank as shown in the picture in my original post]

  • right click the blank drive and select “delete volume”

((( This will completely erase all your data )))

  • Next go and rightclick at the botton the “bar” ( I believe it was black ) of your external drive

  • Click “New Simple Volume”

  • go through the process of assigning your drive, keeping the file system NTFS, allocation unit size default
    Make sure the box for perform quick format is check.

  • click next with the confirmation and it should be done

source: http://wdc.custhelp.com/app/answers/detail/a_id/3865

Hi, if the hard drive is formatted for Mac (HFS+) it wont be recognized natively by a windows computer, in order to make it compatible with both you can format it on FAT32 (4GB limitation per file) or exFat, this will delete your files so do a backup first. There is also a program you can use to read HFS+ partitions on a windows PC, check the link below.


Edit: Too late :stuck_out_tongue:

Is there a way to do it were you Don’t delete the files in the Passport Drive?

I posted a topic on my problem, would appreciate it if you took the time to give it a look and maybe help me out in my problem.

Thank You.

Is there a way to fix this problem without erasing all your data. I have the 3tb WD mybook working on a win7 laptop. I have tried all suggesting in the knowledge base on the WD web site nothing works. is there a way of making your 3TB My book recognized by your computer without erasing data. I have a lot of important files on this drive some saved else where some not. Also I just purchased this 3 days ago. Returning it is not an option because I have personal info on the drive. Please help Thanks!

  Eventually, I fixed the problem by updating WD firmware to the USB3 mypassport 1TB HDD.

  description of my probllem faced>>>

  I was having problem with mypassport USB3.0 External HDD 1TB capacity, it intermitently shows “delayed write failed” and then not readable by WinXP … I frustrated, tried to quick format the HDD, started t backup data to this WD mypassport HDD, initially works fine till about 270GB data content was stored in HDD, then always shows error “delayed write failed” when u connect HDD to USB2 port. Then, tried to re-format HDD without “quick format” option clicked. However, it failed to re-format, and only the  “Device Manager”  abe to recognise mypassport HDD , and window explorer & computer management — disk management cannot recognize the HDD, eventually the problem fixed & resolved by updating the WD firmware to the USB3.0 mypassport HDD.