WD My Passport not detected but LED blinking

Hi,

I have WD Mypassport 2 TB external drive which was working fine until a month ago (Did not use it for more than a month). It suddenly stopped working. I am using Windows 10 OS on HP laptop which has 2 port USB 3.0 and USB C port. I have connected to both of them and even tried with another VAIO PC. The LED is blinking and drive makes the usual sound(nothing abnormal). I could see the drive letter in My PC but it does not show the capacity. I have checked it under Device Manager and I could see the device over there but whenever it try to open Disk Management, that particular screen freezes (no further response). It keeps on trying to open it, I could never open disk management with my USB drive plugged in. When the drive is connected, the shutdown/restart dalso oes not happen and it takes forever. I have close to 1.8 TB of data(close to 1TB of personal data) which is very important to me. Please help me how to make it recognized in the PC. I have tried changing the cable but its of no use, as the cable works fine with both the USB drives that I have. Also I have installed the WD Drive Utilities and the drive is not getting detected over there. Please help!!!

Hi @Kirubs,

There could be a few reasons why the drive is not showing up under Computer. The drive itself could have failed, the partition on the drive may be damaged, the data cable may no longer be good, or the drive may no longer be getting enough power to fully spin up.

Please refer to the following article for troubleshooting steps as the drive is not getting detected:

Title: Windows or macOS Cannot Find My Drive
Link: Windows or macOS Cannot Find My Drive

Here, I suggest you to try the below solutions & check if that works:

  1. Plug the drive into another USB port
  2. Change USB cable
  3. Change drive letter
  4. Reinstall USB controller
  5. Update WD device driver
  6. Run anti-virus software

Hope the above solutions helps to resolve the issue.