Wd my passport messed up


i come to you today desperate this is basically my last hope!

I’ll get straight to the porblem.

It all started yesterday when i was copying some files to my external HDD  (WDBKHX500ABK-01 500GB) so there i’m unpplugging it while copying files by mistake replugged it not recognised by pc this is not the problem i noticed it makes some Beep sound every 15 minutes like i’ve seen videos on youtube that’s a sing of a failure but i don’t think so because when i plug it it takes time to show as DRIVER F but not showing any space or anthing so i followed thie tut i found on youtube telling you how to format it via CMD i went there did “diskpart” and then selected my disk HDD i knew it cuz i saw the space. and i did CLEAN it took alot of time…then i did as shown on the vid create partition primary everthing went okay then i went to disk managment i saw it’s unallocated there so i clicked on it and everything worked fine till it asked me to a fromat…basically the format takes for ever. and i doubt it’s formatting too becasue no proggres here’s the intresting part…i’ve noticed when i formatted it using NTFS as the file system i want it doesn’t show any progress… but i said let’s try something different so i set the file system to exFAT it worked! and said fromat completed…i was soo relived but oh when i came to try and copy a file a small file!,Says “The Operation cannot be completed because the disk is dirty run chkdsk…”

and when i click on it properties i got to tools check disk for errors and check the box for both options i press okay it stays there for a min then simply disappears nothing happened… so this is really my last hope mates please help me!

It seems the dirty bit is flagged in your external drive. First query your drive with fsutil by typing the following command in command console.  fsutil dirty query

It will surely say that the disk is dirty. Now to fix it input this

chkdsk /r

This will fix it IMO…