WD My Passport HDD - 4 TB, being Trimmed on W10. Why?

Hello everybody…

I’m having this problem, only with the WD 4TB external drive in a USB 3.0 port -

Any ideas? My Seagate Ultra Slim 2TB does not exhibit this behavior.

TIA :exploding_head:

Is a WD Engineer available? :tired_face:

Hi all -

Escalated case to “Level 3” Technical Support by Telephone.
Can someone else check to see if their 4 TB My Passport does the same thing?

Again, using Windows 10 Pro, USB 3.0 connect, running:

Defragment and Optimize Drives - native utility in Windows 10 Pro, Build 1803.



That “trimmed” message is coming from Windows optimization message. It likely has nothing to do with the WD drive being at fault. If I got that message, I would google to find out what Windows means by “trimmed”.

If your drive is an SSD, perhaps this link can give you a clue of what is happening:

Let WD Technical Support get back to me and I will respond. Thanks.

Solved the issue.

The cable that came with the drive was too short so I used a Monoprice USB 3.0 extension on it.
When removed the drive worked just fine, but the cable was still too short.

Bought a 3.3 foot cable from Cables-To-Go and that solved it.
Stay away from Monoprice!