WD my passport hard drive not showing on my computer but showing everywhere else (windows xp)

I have an old desktop computer (2006) operating on windows XP. Due to iPad and smartphones I really only use the desktop for storage of photos and music. Desktop runs slowly due to the amont of stuff on it so decided to backup photos and music onto portable external hard drive. I bought a WD my passport ultra 2tb. When I plugged it in it went through the ‘found new hardware wizard’ but came back that it couldn’t install as the data is invalid.

The hard drive does not show up in ‘my computer’.

The hard drive does show up in device manager - USB controllers and WD drive management devices. Both show as location 0.

The hard drive also shows in disk management - volume (blank), layout (partition), type (basic), file system (blank), status (healthy active), capacity (2862.98gb).

I have looked up various forums and it would appear that it doesn’t have a drive or path then it doesn’t show up. I have tried allocating a drive letter but I get the following message “the operation did not complete because the partition or volume is not enabled. To enable he partition or volume restart the computer”

Restarting the computer seems to do nothing - I have tried numerous times, both with the hard drive connected and disconnected.

The hard drive shows in the bios screen (f2 at startup) and on boot startup.

Any suggestions would be greatly appreciated.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Regional Support Teams per Country: