WD My Passport for Mac 1TB and OS X Yosemite

I am very afraid to connect it to my Mac, now that I’m using Yosemite.

Any word of any possible problems?!

I didn’t use WD a year ago, but I know what happened with Mavericks and the data loss problems!

Can anyone ensure me, more likely GUARANTEE, that I can go on and use it with Yosemite?

I have not found an answer anywhwere else…I’ve signed up here just for this.

Also, should I beforehand check with the WD softwares installed on my Mac, if there’s any updates or something?

There is this app called WDFirmwareUpdater, but I haven’t dared touch it yet.

Thank you! :smiley_cat:

Hi, I have My Passport Ultra 2TB, but sadly using Mavericks one day, without any reason, it stopped working (it doesnt event recognise it in disk utility) …just updated to Yosemite and the problem is still present, I might say that I have another mac with Mavericks and it works with the disk like a charm… my advise, backup all your data before testing your drive. 

If anyone has a solution for my problem I´ll love to hear about it.

BR, iMWorks.

Why did I write 1TB? It’s 2TB, so it’s the same exact disk as yours.

Mine only says WD My Passport for Mac on it though, no Ultra. (it’s 2014) (brushed metal on top/bottom, black on sides)

So you haven’t tried with Yosemite? I knew about that Mavericks issue, I heard last year…

It’s weird though that with a different Mac still with Mavericks it works! Happy for you!

Unfortunately I have no way of backing it up, I have no space.

It’s almost full, so it’s almost 2TB of data we’re talking about.

My Mac is 750GB (2012 MBP), and my Time Capsule is 2TB but is used to back up the Mac with Time Machine.

I would have to buy yet another hard disk to make a copy of the WD one, MEH.

I think I better wait for WD to release the proper software for Yosemite, like they did last year for Mavericks.

I really look forward to hearing other experiences…

I have multiple drive i havent experience any problem with Yosemite, i dont use the smartware backup or the password and security features just the plain drive.

I so far plugged in:

1TB WD Elements

2010 1TB WD Passport

2013 2TB WD Passport

No issue and works ok.

If you using the smartware and security password i would make sure you have a backup just incase :slight_smile:

Yes I have activated/use all of that software, I didn’t know it was only bad at the time.

So nope I can’t connect it, I’m sure of that.

I cannot backup, no space…

I’ll just wait for WD to wake the heck up.

I also have a My Passport Ultra 2 TB bought 1 month ago.

With Mavericks it randomly worked, otherwise it was not even recognized at all (formatted for mac).

Now since I have upgraded to Yosemite, it is not recognized at all, although the white LED is on and the disk is spinning.

I am really looking forward for WD to find a solution.

I really hope that they HURRY UP releasing the new firmware.


I just purchased a 4 TB My Passport Pro for a Yosemite mid-2011 Mac desktop.

The drive mounts automatically and is recognized by the OS.

The configuration utility ( does not allow configuration as RAID 1 (two 2 TB mirrors).


This is my first posting on this community and I need HELP! I have a MacBook Pro and just updated to OS X 10.10, Yosemite. My external hd, WD My Passport Ultra 1T, is not mounting. I can see it it in disk utilities, have verified and disk repaired it, but it refuses to mount. There are no updates to download on the WD website. I need to access my files!

Has anyone had this issue and able to resovle?

WD moderator…any suggestions would be helpful. Thanks!!

I have the same query having already killed one WD drive and sseemingly another (after first managing to ‘fix it’ by installing WD SmartWare, only to encounter the problem again without changing anything) with Mavericks.

Very very very frustrating!!!

 There is a similar querey on the Apple discussions board: https://discussions.apple.com/thread/6648125?start=0&tstart=0

HI can you help me ?

i have yosemite and a WD Elements external, but i dont know what to do because seems my mac not recognise it.

what i must to do ?

i have WD ELEMENTS 1TB, is this compatible with my yosemite mac ?

please i hope your response soon, im from Portugal.

my beste regards


Hello pp1963,

as far as I know, and anyone knows I suppose, WD has not yet released updates for their HD firmwares.

Therefore their disks can simply not mount, not be recognized, not work properly, and so on…

I would suggest to just sit tight and not use them, and wait for them to fix the issue.

I hope they release the software SOON, since this has happened before with Mavericks.

I contacted WD last month, at that point in time they told me there were no news and that testing for Yosemite hadn’t even begun!

Now some time has passed, I haven’t tried getting in touch with them again but I suppose there are no changes?

I don’t know why they’re taking so long, Yosemite has been out for a while now…

All one can do is wait, I suppose, or contact them yourself if you want.

I have personally been very lucky, I have a MyPassport for Mac 2TB and strangely it works fine.

But I must be one of the very few, and anyways I haven’t tried updating the firmware or anything…I risk losing my data.

Hope I helped!

I had a similar problem on OS X Yosemite: I’m able to connect through afp, but I wasn’t able over Yosemite to connect using WD client Apps (I just realized that yesterday), my WD Book Live 1TB was connected to a switch connected to my Airport Extreme. I had changed that arrangment and connected the switch to my Time Capsule that was connected to my Airport Extreme. IiMac 27 " is connected to that same airport extreme.

I had made a new arrangement and connected directly the WD Book Live to Time Capsule ethernet ports and Now I can see the unit.

Will test to see what happens…

any solution yet. I just upgraded to yosemite and find that my drive is not getting mounted.

I just bought the WD My Passport for Mac 1 TB… what a **bleep**ing mistake… didn’t work when I got it home, so updated my OS from 10.6.8 in order to use it since it said Lion or Mountain Lion on the box and figured it would be compatible with Yosemite as well but it doesn’t show up once I plug the passport into the USB

Should have just bought the Apple storage device and not cheaped it with the WD piece-of-garbage I’m sitting here with…

I now have to return it… **bleep**ing useless product and **bleep** Staples for selling it to me when I explained that I was going to update my OS to Yosemite…

Who the **bleep** at this **bleep**-hole of a company is going to compensate me for my **bleep**ing precious time that it’ll take to return this piece-of-chincy-**bleep**? 

Any luck with the hard drive and Yosemite? 

Please let me know if yes.

Thanks a lot.

Powered on my WD 4TB MY BOOK external hard drive. I use it to exclusively to archive my images. Many of my archived image folders are empty-thousands of RAW, tif, and jpg files gone! I’m on a Mac Retina 5K OS 10.10.4. Is WD doing anything to help owners of these drives to recover their files?

@marcoie How did it go? Let us know!

@toadityakumar I don’t know of any permanent solution from WD as of yet. I’m afraid the “not mounting” is the most common problem with WD on Yosemite.

@mk202 Don’t worry, you didn’t waste your money. WD are very valuable hard disks, one of the best out there. That being said, there’d been the same frenzy when Mavericks came out. Incompatible, not mounting, not working properly…for a lot of people. The story is just repeating itself now, with Yosemite. WD is not good/fast enough at making its software compatible when a new Apple OS comes out, that is for sure. But don’t throw the disk away just yet, a solution will have to come… Yosemite has been out for a long time now, they must work with that.

@brian_lara Actually, I guess I’m one of the very lucky ones, my WD MyPassport works fine on Yosemite! One day I was just sick and tired of waiting after months of doubts and fears,  so I just plugged it in. Risky move, risking a lot of things. But it mounted, it opened, and my stuff was all there. And it’s been like that ever since, there have even been small updates to Yosemite, and none of them seem to have affected the compatibility. I do have the standard WD software installed on my WD drive (that’s usually what f*cks things up and creates problems), so I really really really don’t know why or how it is compatible with Yosemite for me. But nonetheless I fear everyday that it might end! WD needs to solve the problem, once and for all. So my personal situation is “solved” as long as it works, meh. Would like to know if I’m the only one?

@harian I am very sorry to hear you’re among those who had loss of files upon mounting on Yosemite. Even if I don’t think files actually get “deleted”, they must still be there I’m almost sure of that (I’m no expert, but I don’t think a software incompatibility can erase a disk at that level). WD doing something, that’s a though one. No one really knows… I had personally (sort of angrily) contacted them, upon the release of Yosemite, so almost a year ago now, demanding explanations and solutions. They told me the “testing” of their WD drives hadn’t even begun, on Yosemite. At that time…now I don’t know. I do hope something is moving, it would be really weird of them otherwise. I suggest you to directly contact WD and request explanations/anything you need…

Bottom line, I now personally find myself with a working WD MyPassport 2T drive, no idea why. So I haven’t contacted them anymore, it’s been almost a year now I don’t know what the deal is right now. I suggest anyone who has problems (the majority) to contact them, let your voices be heard loud. They must have done something in one year, some software update, some firmware update, testing…something! 

Now El Capitan is coming, I fear for my drive, that compatibility will be over. And it’ll be the same old story all over again, like with Mavericks, like with Yosemite. WD wake up.

I also suggest y’all refer to this thread as well, looks like the biggest one for these issues, and there are some “solutions” that users have tried (obviously go to the last page, there’s posts from 2015):  http://community.wd.com/t5/External-Drives-for-Mac/External-Drives-for-Mac-Experiencing-Data-Loss-with-Maverick-OS/td-p/613775

Just received a passport ultra plugged it in to my macbook air (el capitan) installed the mac utility from the passport–and it won’t save any files. Called WD service and after a runaround was informed that ‘this device is not recommended for macs’. They said I could reformat it but would risk corruption problems. Bottom line they said it’s only good for pcs running windows. Thanks a lot