WD My passport external drive detects but not working

1TB WD My passport harddisk suddenly stopped working. drives not visible in My computer.

Under “disk managment” - Drives are visible without lables. right clicking on these drives major options (like change lable) are disabled. I tried to check on xp as well as windows 7.

Other observations - LED on, harddisk vibrates after insersion as in normal case.

A day ago the harddisk was working properly in the same laptop.

There are important data stored inside it. Please guide.

Do I understand correctly that in Disk Management the Drive Letter options are grayed out? Not showing in My Computer can indicate a problem with or lack of a drive letter. If the Drive Letter options are unavailable you may be having a problem with USB storage drivers. You might also try using a different cable if one is available.

To correct possible USB driver issues, look at the guide linked below, and run the DriveCleanup utility which is linked to in the guide. This should at least eliminate some possibilities if it does not fix the problem.


Yes, Drive letter options are grayed out in Disk management.

FYI, I have also tried with different usb cable. Also I checked drivers. (by connecting another wd hard disk, as it works fine.)

Also I tried to recover data from some data recovery softwares (like 7 partition recovery, etc.), but it is taking too much time (in my case it took more than 14 hours and i had to close inbetween)

is there file system (Fat32 or ntfs) corrupted? if so how it deal with it? Please suggest.

Sometimes driver problems can be specific to certain units. This is because of the way Windows handles the installation of USB storage drivers (the balloon which pops up saying “Installing driver”.) These drivers don’t actually go away when the device is disconnected, and may cause conflicts involving such things as the drive letters which have been assigned.

The guide explains these issues and offers a fix. I have used the cleanup utility without ill effects. It found a remarkable list of files and registry entries. It really is worth a look. If all else fails, booting to a Linux Live rescue CD may give you a chance to recover your data. Once that is secured, using the WD Diagnostic utility (Data Lifeguard Diagnostic for Windows) to do a Quick Erase (write zeroes to the first and last few sectors) should put the drive in a clean and unallocated state where Disk Management can deal with it.

1 Like

Hi Kieren,

Thanks for reply and for your time. As I have never worked on Linux, so I have not tried on it.

Finally after too much struggle, I was able to collect my data through third party partition recovery software. Any how it took too much time i.e. in my case it took more than 11 hours, but now I have my data :).

Other thing, after I tried to format my drive in NTFS format, the format couldn’t complete. After that I tried to format in exFAT (quick format)  than it worked and now I am able to use this drive. I don’t know usage of exFAT type partition is advisable or not, please suggest.

Also FYI, I also tried to recover drive with wd’s “Acronis True Image” software but it couldn’t recover.

Was the failed NTFS format after a Quick Erase with WinDLG? If so, that’s kind of puzzling–not sure what happened there.

I have only encountered exFAT on certain large USB flash drives. I’m not really sure of pros and cons. If it is working, it’s probably just as well to let it be. I’m really glad you got your data off. It’s not surprising it took a long time. Recovery jobs usually have for me.Good work and congratulations!

If you should ever need them in the future, don’t be too intimidated by Linux Live boot situations. I am barely a novice with such things, myself. The times I have used them it has been in a graphical desktop not too different from Windows. I ended up there because the drive I was trying to recover data from kept Windows from booting if it was connected. I hope you don’t find yourself needing to go through this again, though!

For quick format, I went through Disk managment and not WinDLG.

Again thanks for sharing your opinion.

There is a good chance that running the Quick Erase will make NTFS formatting possible. This is a different operation from formatting. Even removing the partition does not fully clear the former state of the disk. In addition, Data Lifeguard testing will give more extensive information on the drive’s condition.

It is a little worrisome that the NTFS format would not complete. If it were mine, I would want to resolve that doubtful situation.

Hi: Need your advice, can you please tell me what data racovery software you used? I havea very similar problem, my laptop can find the WD HDrive but I can not acces it. When I click on computer I can see the external drive. And now I see it as external drive. Hope you can help me.

Hi Mixtli,

EaseUS Partition Recovery Software has been used to retrive partition. But remember its free version will retrive up to certain limit only say 1GB. So to get full data one need to have full version. Once you get your data, you can format the drive from disk managment (Delete and format).

Thanks Kieren,

Actually I was having two partitions on harddisk. After getting problem, I tried to seperate one more partition from 2nd one to get data backup on same drive. But It was not allowing me to format in NTFS format on perticular new drive. Once I had my data, I was able to format in NTFS for older drives. And Now I did format in newer drive also in NTFS too. I don’t know why initially new partiton was not able to format in NTFS. 

I am very glad to hear that you got it all straightened out! Congratulations!

Hello all,

I’ve been using the WD My Passport drive as a backup disk. By accident, I deleted some files from it and used the MiniTool Power Recovery to recover the files ( http://www.powerdatarecovery.com)..) Unfortunately, I wasn’t successful. Windows 8, doesn’t recognize the drive. I’ve removed the driver and reinstalled it but to no avail. I’ve tried some of the suggestions from the forum, using WD diagnostic util, it doesn’t even detect it. I’ve also edited the registry and removed the lowfilter and uperfilter as someone suggested and the result is the same.

I’ve tried a different cable, as I have a second drive and also connected it to another PC on a USB 3.0 port and windows 8 and the problem persists.

The drive spins, the light turns on, there are no issues or yellow indications in device manager. I checked the USB button at the bottom right corner, to see if it’s listed and remove it. That I can do. However, before I do that, it doesn’t show in disk management!!

I’m writing this, as I’m one of many that have had a bad experience with this drive. If someone has a last minute idea of something else I should try, please let me know! It seems that the partition table lost its signature or something else has damaged it.

I probably should kiss it good bye, and or use it as paper weight, or door stop, or if anyone has a different idea, please let me know. If not, I’ll opt in buying a seagate drive.