WD My Passport Essential SE: not found on computer

Hello,

Since today my WD HDD (WDBABM0010BBK)  is not being found on my computer. I have tons of photo’s stored on my device and I haven’t backed up all of them so I hope someone can help me out.

  • my WD HDD is also not being found on two other computers
  • I tried another USB cable
  • the light on my WD HDD is working
  • the light on my USB hub is not burning when the WD HDD is inserted (it does with other usb devices)
  • HD WDD not found in Disk Managament 

I hope someone can help me out with this. The only thing I need to be sure of is wheter the data can be retrieved somehow.

Kind regards,

Brein 

Hi there

I can see you tried all the troubleshooting steps, I can just suggest to test the drive on TesDisk to verify if the drive has data corruption or bad sectors, if the software can’t repair the drive then contact WD to replace the drive.-

Thanks for the reply.

Is it possible anyway to test the drive on TesDisk if the drive cannot be found at all?

How about trying a firmware update? Would that erase the data on the drive completely? Or will the data be kept?

Regards,

Brein 

A firmware update will not delete the data on the drive, but if your drive is not recognized on the computer I don’t think you will be able to update it

Yes, but the same counts for testing it on TestDisk, doesn’t it?

Edit: tried TestDisk . TestDisk wasn’t able to find WD drive.

Did you try the drive without the hub and in different ports? One on the back of a desktop may work better. About the only other thing to try is a powerbooster cable. It is Y shaped and uses 2 USB ports. It doesn’t sound good.  About the only way to get data off would be probfessional data recovery. Since this is a drive with Smartware the data is hardware encrypted whether you used it or not.

Joe

Thanks Joe, clears up a lot. 

I did try without the hub and in different ports, also on the back of the desktop.  Will try to get my hands on a powerbooster cable and otherwise will look for professional data recovery options.  

Thanks for the help all. 

anzaieiji, if you are using IE9 please visit the link below:

http://community.wdc.com/t5/Forum-Feedback/IE9-and-WDC-Forum-Compatibility/td-p/167170