WD My Passport Essential 500 GB - Freezes Computer, Now not recognised at all

Hi everyone, hope you can help me!

I was transfering files to my Passport Essential (only used for backup) when the transfer stopped mid way and then froze my pc.

I am using windows Vista 64 bit.

After re-starting my machine, on connection it froze my PC. The only way to resolve the problem was to remove the USB connection and then all would be fine again. 

After researching, I tried;

Disk Mananger = Nothing

Test Disk = Nothing

Lights ar eon, and the hard drive is working - no clangs or bad broken drive noises.

I have also downloaded the firmware updater which did connect to the hard drive - however after updating the firmware it attempts to update the driver software via windows and hangs.

I have tried the Passport on a colleagues windows 7 machine and it will not recognise after the dirver installation. It says it is connected - but when I try to “safely” remove it just hangs again.

Is it bad news for her? 

Thanks in advance!

Ok, have now tried on another machine and after taking an age to resognise the HD - it now says it has to be formatted. Again I cannot view any file structure.

Is there any way I can rescue this?