WD My Passport drive showing but not able to access


I have been using WD My Passport for last one year and suddenly from last week I face an issue.

When I connect, drive is showing as D: in my computer but not able to access. Not responding when I try to open the drive.

I tried in all ports and also tried in another laptop. same problem everywhere except I am able to access when I connect in my TV.

Also I checked online regarding the same problem and tried but still not helping.

Also I am not able to open Disk Management when the device is connected. It says connecting to virtual disk service but no luck here also.


Kindly advise me to get it work. Will be very helpful.

Note: Device is running properly, LED light blinking, mild vibration.



Hello there and welcome to the WD community.

Try a different USB cable to see if the drive comes up on the computer, its strage that you can only access it from the TV.  

Hi ArMak,

Drive comes up in computer as D: but not able to access it. When I double click or right click, it stuck for hours and not responding. After sometime the drive vanished from computer with a popu(D: is not accessible. The parameter is incorrect).

Also I tried using different cable and that also couldn’t help. :frowning:


i am facing same issue as you. Please mail me if you find any solution. 

Mail Id : [Deleted]

I’ve posted this solution in another thread but since this thread is based around the same issue here it is again