WD My Passport Doesn't show files on my Laptop


I’m trying to take some files from my Cousin’s WD My Passport HDD but when i connect it on my Laptop i can’t find any files in it, it shows files such as: Extras, WD SmartWare.exe, User Manual, Unlock, etc… but it doesn’t show any files from the hard disk, the files shows when i connect it to my cousin’s laptop, i’m using Windows 7 and he’s using Vista, and it shows 0 MB free of 614 MB in my Laptop, and it doesn’t show in Hard Disk Drives, it shows in Devices and Removable Storage

Anyone can help me please ? i need to take those files…

if this is an old drive chances are you are just seen the virtual disk that comes with smartware

what name is the drive showing on computer?

try going to Disk Management to see if the drive appears there

What OSs are you using on the 2 PCs? Try going into folder options and check show hidden files.


I don’t think that’s the problem, because the hard disk shows that it has 0 MB free of 614 MB while it isn’t, and it shows with the DVD drivers and stuff

that is NOT the hd… that’s the VCD …

did you check on Disk Management

Yeah i did, it’s there but shows as CD-ROM 1, also its name in Computer shows as CD Drive (L:) WD Smartware while its real name is “The Family” in my cousins laptop

@ Joe_S Yeah like i said my OS is Windows 7 and my cousins OS is Vista


I am facing a similar problem. One fine day the drive stopped showing in My Computer. I am using windows 7 and tried it on another laptop with windows vista as well. I have a portable My Passport hard disk of 512 GB.

When I open disk management, it asks me to initialize disk 1 (which is my unallocated external hard disk) and when I try to it gives me a message saying that it is write protected.

I also tried using another cable to connect but even that doesnt help. The disk is showing when I try to safely remove hardware.

Please help! 

Thanks in advance.

the drive is password protected or corrupted…

if you have a password you will need to unlock it…

it corrupted must likely too corrupted to fix

replacing is the last option but you can look around for partition recovery utilities before replacing

does the drive make any sounds? slight ticking perhaps