WD My Passport doesn't get connected and light blinks

Hi all,

I have a My Passport drive that has always worked well. It has some old back-ups and I haven’t used it for a few months. Today I wanted to check a few files on it but I cannot get it to work. When I connect it, it keeps binlking and keeps making a short sound. I have tried with different USB ports, different PCs and different cables. Always the same issue.

I also use EaseUS, a recovery software for hard-drives, but it cannot detect it.

I wonder if there is software issue as I both my PCs have gone through several updates on Windows 10.

What can the problem be? Any idea?

Hi mauroskov,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

Thank you for your response.

I actually connected the drive to a Mac and it started to work. After that I connected it again to my PC and it worked too.

Sometimes technology is so strange, so moody I would say!