WD My Passport-Connects, works, but randomly disconnects

Like the title, my WD passport can be accessed however it will randomly disconnect whether it’s being used or not being used. It happens on both my laptop and desktop. I did a Quick Drive Test, Drive Status Check, however it doesn’t usually stay connected long enough for a Complete Drive Test to be completed. I do notice that when it does disconnect it seems that it goes into Standby mode because of the flashing light every couple of seconds, not sure if the harddrive is actually going into standby mode but the light is saying it does. I’ve made sure that the options for the USB ports don’t disconnect or lose power. It’s becoming increasingly annoying as I’m trying to work off photos on it and it randomly disconnecting.

Hello ike32mike,

Did you check after changing the USB cable or connecting with another computer?

I do not have another USB 3.0 to Micro B cable and I tried using my desktop and it ran into the same issues mentioned above as on my laptop.

I too have been having the same issue.

Just spoke with tech support and have done the Quick Drive Test (which passed), and am now doing the Extended Test. I will forward the results back to their email they have sent to me.

I bought two identical 4TB WD Elements 25A1’s and noticed fairly quickly that one of them was having issues. I tried three different computers, and used the other IDENTICAL cord from other 4TB WD Element drive with the exact same results for the drive in question.

I even went so far as to call the drive “might be bad drive” so that I could be for certain not to confuse the two, since they are 100% identical.

I have come across many people having this issue with brand new, out of the box, drives.

I personally have had a very good record with WD for quality.

500GB WD
4TB WD x(2)

I just feel like this is a known issue.

#: ref:_022019-13632682

The case number is: 13632682

I think it may connection problem or drive internal problem like bad sectors something. Advice try one pc and recommend use NAS storage instead of usb external hard drive.

I have the same problem with a brand new My Passport Ultra 4 TB.
I purchased 2 identical drives to use as a safepoint for my MyBook Live Duo NAS drive.
One of the drives works but the other get intermittent disconnects which kills the safepoint process.
I have erased everything and started over and also reformated the drive
It passes the check drive tests. I think it is a connection problem with the new drive.

I am having the same issue with my Passport 4TB. This is the 2nd one I purchased, and the 1st is still going strong. This one just started the random disconnect this week. I ruled out the cable and computer as issues. It does reconnect with the slightest touch to the cable, which makes me suspect a poor solder connection inside the drive unit.

It has never been dropped and always inserted and ejected properly. As a video editor, I work with portable drives every day and I treat them with care so they have a long life. I’ve had this drive for 5 months, it is removed for file transfer about once per week, so it’s not due to excessive use either.

I agree with @dirkdiggler90210. I’ve had a positive history with WD drives, and I think this is a known issue.

Where are the Quick & Extended drive tests? I’d like to rule that out too.

Update: To answer my own question, the drive tests need to be downloaded. On the main support page, click on ‘Downloads’ at the top of the page. Then under your system options, select “WD Drive Utilities for Mac” (or Windows for PC). Download and install the software.

I contacted support and currently running the tests as well.

UPDATE (that I should have posted much earlier):

My HD was returned in exchange for a replacement, and WD had a quick turnaround time. There have been no issues (yet) with the replacement drive.

My theory: there is an internal solder connection or PCB quality issue, likely along a power path. Without looking at schematics, I couldn’t guess where to look first. But I’m sure that the actual number of impacted units is much larger than the handful of people here who actually took their time to search, post, and discuss the issue. And there is no official recall or acknowledgment of the problem because WD knows that most people will just buy a replacement anyway. :face_with_raised_eyebrow:

Bottom line: if YOU have this problem, do the diagnostic tests, and when they pass - submit for a replacement drive.

I too have this problem. I run linux and every time the disc disconnects, it reconnects as root and I cannot access it.

Unfortunately we have the same issues; have there been any updates? has it been resolved?

Had to send the unit back.

The new one works well.

I have the exact issue as you do. It disconnects with a slight touch to the cable. And it takes forever to be mounted again. I have a WD Passport Ultra 2tb using with a Macbook Pro 2019

Wondering if there is any update on this issue, because I’m experiencing the same.
BTW, I did try another cable, one that works well with my other Seagate external hard drive, to no avail.
This is very annoying.
When I play videos stored on the drive, because the drive disconnects, sometimes it causes blue screen, which took me a while to figure out, experimenting various possibilities.

I have the same problem with a WD My Book 2 TB USB 3.0 drive on a Windows 10 Pro (64b) machine and have gone through all of the other steps to eliminate possibilities and none of them worked. Swapped drives, cables, power cubes, check for SW and FW updates, Chat with a WD rep that said out of warranty and had a bad drive. Horse Feathers ! This is the solution:

Go to Device Manager > Universal Serial Bus Controller > USB Root Hub (USB 3.0) > RT Click for properties > Power Management > UNCHECK “Allow computer to turn off thgis device to save power”

I had a similar problem as decribed above . disconnecting my brand new WD 4TB drive every 10 min.
the last 3 hours I connected to the USB port of my independant screen .( not on any USB port of my laptop) and had no problem since then… not the best solution but at least it works. it seems to confirm it is a power problem not a bad cluster.