WD My Passport: cannot be accessed


I need some help… really badly… :confounded:

My  1TB WD My Passport EHD cannot be accessed in my computer. It can be detected though but as a local disk (G) only ( i have the disk named before). 

I have this unit with me for 10 months now. The last thing I did was to transfer files from my computer and then it was interupted due to an error message and then everything went unresponsive. I rebooted my laptop and tried reconnecting my EHD but it was not detected. I tried using other computers but to no avail.

My friend suggested that I should re-install the EHD driver 'coz it might be the reason for the non-detection. And i did. It worked. The EHD was detected but then cannot be accessed. The light from my EHD just keep on blinking.

I’m currently using windows 7.

I’m really worried since i still have important files in my disk which I haven’t transferred yet.

Any help is much appreciated. 


How is the drive showing on disk management?

See the following link for assistance.


Also you can try testing the drive with the DLG tool.


Do you have a password on your passport?