WD My Passport 1TB USB3.0 WDBBEP0010BBK-01 "no driver found" during installation in Windows 7 Pro

Hello all,

I searched google and microsoft help, for this issue but none seems to work.

I just purchased a WD My Passport 1 TB USB 3.0, P/N# WDBBEP0010BBK-01, Model# WDBBEP0010BBK-PESN.

When I plug it into my ASUS Laptop running Win7, the “no driver found” came up during installation. I checked the device manager and the portable HD “My Passport 0748” shows up under “Other Devices”

Then I went to control panel, under Control Panel > Hardware and Sound > Devices and Printers, the drive shows up under “Unspecified”.

Tried under “Device Manager” to uninstall, unplug the device, and reconnect it to the laptop, also same error “no drivers found”. Under “properties”, shown error code 28.

Tried on all 3 USB ports, also no luck.

Read somewhere about checking the device through Disk Manager, the harddrive does not show up here either.

Tried Clean Boot as mentioned in ( http://support.microsoft.com/kb/929135),,) also same issue.

When I plugged the portable drive into another computer running Windows XP Home, the hard drive can be installed and shows up as a letter drive in My Computer. Seems ok to look into the content of the drive. So I figured that at least the portable harddisk and the cable is OK. 

So, what do I do now?


Click on the link below to get a full list of the drivers for the portable unit. this should help you


Found a solution to this problem. Turns out that usbstor.inf and usbstor.pnf were missing from the drivers.  http://ckon.wordpress.com/2011/04/08/windows-usb-problems-usbstor-inf/

After copying the appropriate files, it works!

1 Like