WD My Passport (1TB) drive stopped working!

Dear All!

I have a 1TB My Passport USB 3.0 hard disk (WDBACX0010BBK-01). I bought it about six months back. It had been working great up till now.

The drive was attached to my computer USB port when i turned the computer on. The last time I shutdown my pc the drive was okay. After turning on the pc i opened up My Computer expecting the Unlocking Drive to show up however it didnt show up. I tried to refresh the window but it got stuck.

Now since then the drive has been showing the same behavior. When i plug the drive into the USB port:

  • the usb device icon appears at the bottom right corner of the taskbar.
  • the drive shows up in the System Device Manager as “WD My Passport 0740 USB Device”
  • When i go to My Computer right after connecting the drive the drive doesn’t show up. Upon trying to refresh the window gets stuck until i disconnect the drive from the USB port.
  • The drive itself doesn’t show any abnormal symptoms when connected. Its white LED blinks sometimes intermittently and sometimes constantly. I can clearly feel the drive rotating without any abnormal sound. It also gives sound as if a read/write operation is taking place.
  • I do hear one single click after about 3-5 minutes of the drive being plugged in. But none afterwards… the drive keeps rotating and LED light stays operating as well afterwards.
  • When i unplug the drive i very briefly see the i:\ drive in the My Computer window.

The USB cable seems fine and so does the connector. I didn’t drop the drive. However i had a practice of not removing it when  shutting down or starting up my pc. Basically i was using it as a permanent external drive.

I can’t really figure out the problem. Need anyone’s help… Data recovery is of priority here!

Best Regards,

the partition got some how corrupted

use a recovery application like TestDisk  to repair and get the data

i tried using testdisk and also the other utility i.e. photorec downloaded along with the testdisk…

when i connect the MyPassport drive with the pc and run the testdisk , the utility keeps displaying “keep waiting” message in the window. Same thing happens with the photorec utility…

if i disconnect the harddisk the testdisk utility shows me the drives connected to the computer… one of which is the mypassport even though its disconnected now… even if i reconnect the drive to the pc now and try to recover or analyse the data the utility gives read error and write errors for all sectors of the drive…

i think when i disconnect the drive the residual info stays with the utility and the utility keeps using that info for further actions on the drive while in real it cant really see or detect the drive…

need your comments on this…

Drive is failing, software can actually do more hard at this point then anything else.

In situations like this its best to have the drive assessed by specialist who recovers data. I am sure there are companies like that in your area. If your drive keeps stalling like this, its most likely due to one of the heads.

This videoshows identical scenario. Drive started to act up, software kept stalling… And it lead to this. When we got it for recovery it was way too late. Damage was on all six sides of the platters. :frowning: not fun.