WD My Passport 0730 USB Device - 500GB _ driver not appears in my computer

Hello Everyone

i have a problem with my usb device :

when i connect to the usb on my computer the computer can read it but no drive appears on my computer or on the disk mannagment and when i restart my computer the computer opens verey slow 

as it appers on the picture

i have data on my hard disk an it is = 300 gb almost

Error.JPG

what i have to do

I have the same  model and the same problem

plus windows 7 ask me every 30 seconds if I want format

certainly try to format it but fails

even with the windows xp disk in non OS mode and nothing 

the only thing that I don’t  try is this

As a remedy, you can purchase USB Y connector that would occupy two USB ports.

“in  Mabkay post”

KarimMS wrote:

Hello Everyone

i have a problem with my usb device :

 

when i connect to the usb on my computer the computer can read it but no drive appears on my computer or on the disk mannagment and when i restart my computer the computer opens verey slow 

as it appers on the picture

i have data on my hard disk an it is = 300 gb almost

what i have to do

what length of usb cable are you using?  it must be no more than 18 inches.  you could try the passport on another computer, and maybe get the power booster cable from wd tech support to see if that works.  otherwise, your drive has failed.

Orlandogt wrote:

I have the same  model and the same problem

plus windows 7 ask me every 30 seconds if I want format

certainly try to format it but fails

even with the windows xp disk in non OS mode and nothing 

the only thing that I don’t  try is this

As a remedy, you can purchase USB Y connector that would occupy two USB ports.

“in  Mabkay post”

what does it say about your drive in disk management?  your issue sounds like a file corruption problem.